Support » Plugin: SharePress » [Plugin: Sharepress] Plugin Activation Throws an Error

  • I am installing and activating Sharepress on a single blog within a multi-site installation. The domain of my blog is a different domain from the root site via Domain Mapping. I have multiple plugins on the site and there have been no problems so far.

    When I activate the plugin, I get the following error:

    Warning: strpos() expects parameter 1 to be string, array given in /[my site root]/wp-includes/link-template.php on line 2027

    Is this a result of multi-site, of the domain mapping, or what else?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Aaron Collegeman


    @saracup, excellent questions. Unfortunately I haven’t tested the setup you’re describing. I am, however, getting ready to embark on just such a project. I will let you know what I discover.

    Thank you. I’m anxiously awaiting SharePress pro. We’ll be using it on a multi-network installation (like multi-site on steroids). Would love to get this to work!

    Same error in link-template.php, but on line 2128 I’m fixed by changing sharepress-lite.php on line 628:
    From wp_enqueue_script(‘fancybox’, plugins_url(‘sharepress/fancybox/jquery.fancybox-1.3.4.pack.js’, array(‘jquery’)));
    To wp_enqueue_script(‘fancybox’, plugins_url(‘sharepress/fancybox/jquery.fancybox-1.3.4.pack.js’, ‘jquery’));

    Plugin Author Aaron Collegeman


    @57ar7up, thanks for the tip. I’ll see that this fix gets implemented in the next release.

    Sharepress throw me this after install and activation;

    Fatal error: Uncaught exception ‘Exception’ with message ‘Facebook needs the CURL PHP extension.’ in /srv/www/ Stack trace: #0 /srv/www/ require() #1 /srv/www/ include(‘/srv/www/highac…’) #2 /srv/www/ plugin_sandbox_scrape(‘sharepress/shar…’) #3 {main} thrown in /srv/www/ on line 4

    Problem solved, installed php5-curl into my Apache, works as a charm, waiting for the pro version!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: Sharepress] Plugin Activation Throws an Error’ is closed to new replies.