Support » Plugin: Polylang » [Plugin: Polylang] Language switcher does not appear

  • Let me start by thanking for this great plugin.

    I do encounter one problem on my site ( In the “Menu” settings, I checked the first, third and fifth option (append to menu; flags; hide current). However, there is no switch whatsoever. Neither in the horizontal, nor in the vertical menu (I would prefer it to be in the horizontal menu, this is also the menu that was set on the same preferences page and therefore the menu to which I expected the switch to be appended to).

    For now, I have added the switch to the footer using a widget, but that is not the best solution.

    The theme is generated with Artisteer3. However, the preview of WP 2010 and 2011 themes also does not show the switch either (but does show the widget in 2010, not in 2011). I have already tried to de/reactivate the plugin.

    This is not an urgent thing and problably something I misunderstood, but I would like to fix it eventually. Any ideas?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Chouby


    Please look in the FAQ included in the doc. There is a link to a topic in this forum which discusses Artisteer generated themes


    thank you very much for the plugin.
    Same issue, the switcher doesn’t appear in the menu.
    When I use the widget, the menu doesn’t change neither.

    – 2 languages have been set up
    – 2 menus have been configured
    – Displays a language switcher at the end of the menu
    – Displays flags
    – Keep /language/ in pretty permalinks

    Here is the work in progress:

    Here are the files of the theme via wetransfer:

    could you help me figuring out what is going wrong?
    Thank you for your help

    I solved my first issue by reading it more carefully the FAQ.

    I replaced a line of code by:

    <?php wp_nav_menu( array( 'container_class' => 'menu-header', 'theme_location' => 'primary', 'link_before' => '<span class="pag_l"></span><span class="pag_bg">', 'link_after' => '</span><span class="pag_r"></span>' ) ); ?>

    I have now a new issue:

    The posts of a category “Tech” do not switch from language.
    I made a translation of the existing posts without success.
    Do you have a good idea?

    Thank you for your help.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Polylang] Language switcher does not appear’ is closed to new replies.