WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Page-Links Plus] Installation & Configuration

[Resolved] [Plugin: Page-Links Plus] Installation & Configuration

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author Studio Hyperset

    @studiohyperset

    Hi, Ashish:

    Can you provide a bit more detail about the trouble you’re having? I’m sure we can fix it.

    I’d also be interested in seeing any screenshots you can provide.

    Feel free to email SH if needs be: info /at/ studiohyperset.com

    Plugin Author Studio Hyperset

    @studiohyperset

    This issue was related to plugin folder names per the purchased .zip file (i.e., ../wp-content/plugins/auto-pagination-v1/ vs. ../wp-content/plugins/auto-pagination/).

    The error’s been resolved for Ashish and in the PLP shop.

    I just downloaded your PLP single page plugin, installed it, activated it, and afterward bought your 3-plugin PLP package (styles-auto-scrolling.zip). I then installed all three of those plugins, making sure that the PLP single page plugin was functional, and that I installed the auto-pagination plugin before installing the scrolling plugin. Whenever I activated any of the three bundled plugins I got a warning message telling me to “Download, install, and activate the basic Page-Links Plus plugin before activating…” even though the basic PLP plugin is installed and appears to be working properly. When I go to any of the three bundled plugins’ settings page I wind up at the PLP single page settings page (see the attached screen shot). This is on WP 3.5. <https://dl.dropbox.com/u/1377596/plp.jpg&gt; You can see from the screen shot that the framework appears to be installed properly.(I overwrote the site name in the framework statement)

    It’s almost as though the three bundled plugins can’t find the single page plugin, so perhaps the path the three are looking for isn’t where the single page plugin installs (I installed the single page plugin via the WP plugin menu)

    FYI– the PLP single page plugin is installed in “page-links-single-page-option”, the auto-pagination is installed in “auto-pagination”, the pagination style plugin is installed in “pagination-styles”, and the scrolling plugin is in “scrolling-pagination”

    Plugin Author Studio Hyperset

    @studiohyperset

    Hi, Susan:

    First, thanks so much for your purchase, and I’m sorry for the trouble you’re having.

    Second, I’ve just sent an updated batch of files to the email address you used to purchase the PLP module set. Let us know if this doesn’t fix the various issues.

    The updated plugins installed with no problems. Thanks for sending them!

    However, they don’t seem to want to work for the most part. If I set the auto-pagination plugin to paginate at 3 (or more) paragraphs I don’t get any pagination in a 10 paragraph test page. For the same page, if I deactivate the auto-pagination plugin and I manually introduce page breaks, I get correct pagination and the “single page” plugin works (ie, I get the default WP pagination along with the “single page” choice at the bottom of the page). If I reactivate the auto-pagination plugin while the manual page breaks are still in place, and I choose to have the auto-pagination plugin ignore existing page breaks, I get no pagination at all in the test page– just one long single page (ie, if I check the “Ignore existing <!–nextpage–> tags?” box I lose all page breaks, and if I uncheck it the page breaks return). So that would indicate that part of the auto-pagination plugin is working (the part that ignores page breaks) but that the pagination part of the plugin isn’t. And of course I can’t tell if the styling is working because the auto-pagination plugin isn’t working.

    Any ideas?

    Plugin Author Studio Hyperset

    @studiohyperset

    Hi, Susan:

    Let’s try this first.

    Uninstall and delete all the plugin files on your server. Then, reinstall the files I sent you via email.

    If that doesn’t fix the issue, we’ll start digging into the details.

    Thanks for your patience.

    I hope you’re not saying you want me to uninstall and delete *all* of the plugins I’ve installed and configured on the site, but rather you want me to uninstall and delete all of the PLP files.

    Plugin Author Studio Hyperset

    @studiohyperset

    Hi, Susan:

    That’s correct. For now, leave your other plugin files as they are. There may be some sort of plugin conflict, but, for now, let’s just uninstall and delete all the PLP plugin files and reinstall the files I sent you via email.

    OK, I uninstalled all the PLP plugins and reinstalled just the single page plugin, made sure it was activated, checked the settings and saved them. Then I installed the auto-pagination plugin, made sure it was activated, checked the settings (5 paras per page) and saved them. (The plugins I installed were two of the four you sent me.) And then I checked a long article that should paginate to maybe 4 pages, and nothing– just a long single page as usual. So I checked another long article that should paginate to maybe 3 pages, and again nothing.

    If I manually put page breaks into an article, it paginates correctly; but if I choose for auto-pagination to ignore the page breaks I wind up with one long page. This is the same as before.

    Plugin Author Studio Hyperset

    @studiohyperset

    Hi, Susan:

    I’ve tested these variables on a “clean” install of WordPress 3.5, which is running the Twenty Eleven theme and no plugins save Page-Links Plus. I’m afraid I can’t recreate the problems you describe so I assume the issue lies elsewhere, most likely with an outdated version of WP or a conflicting plugin.

    Also, make sure you’re wrapping your content in best-practices HTML tags (e.g., <p>,
    <ul>, &c.).

    Page-Links Plus looks for those tags in a number of ways.

    Keep us posted on this issue.

    WordPress 3.5, content is simple paras wrapped in <p></p> tags. Simple. I suspect it might be a plugin conflict, but I don’t have the time to track it down at this point. When I get a chance I might do a mirror install of the site on my local development server and see if I can backtrack through the plugins until I find the culprit.

    Plugin Author Studio Hyperset

    @studiohyperset

    Hi, Susan:

    That’s exactly how I would handle the issue. Thanks again for your purchase.

    HI,

    I just bought and installed the page-links pack. I am having issues with activating Auto Pagination and Scrolling Pagination.

    I installed the free page-links plus then installed styles. I am now trying to install auto pagination but i am getting the message

    Download, install, and activate the basic Page-Links Plus plugin before activating the Auto Pagination module.

    This is already installed. Please advise.. thanks

    -Elvin

    Plugin Author Studio Hyperset

    @studiohyperset

    Hi, Elvin:

    I’ve emailed new (beta) files to the email address you used during purchase. Please delete whatever plugin files are on your server and replace with the ones I sent you.

    If you don’t see the files in your inbox, feel free to reach out to me at info [at] studiohyperset.com.

    Thanks for your purchase.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] [Plugin: Page-Links Plus] Installation & Configuration’ is closed to new replies.