Support » Plugin: Plugin Organizer » Plugin Organizer is not set up correctly

  • Hi again Jeff,

    After the last update it shows me this warning :

    Plugin Organizer is not set up correctly.

    You are running an old version of the MU Plugin. Please use the tool provided on the settings page to move the updated version into place or manually copy . . .

    I manually deleted the old version and copy the new one and the message is still showing.

    Thank you as always for the support.

    Regards.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Same problem here.
    Need some support.

    Plugin Author Jeff Sterup

    (@foomagoo)

    Go to the wordpress plugins page and click Must-Use. Check that the version number for Plugin Organizer MU is the same number as Plugin Organizer on the standard plugins page.

    Thanks Jeff, but version numbers are the same. Problem not solved yet.

    Plugin Author Jeff Sterup

    (@foomagoo)

    If that is the case then I’m not sure why it is displaying that message. It does a check to make sure both version numbers match and the only way it displays is if they are different. Can you edit the PluginOrganizer.class.php file on line 628 and paste the following code in place of the return statement that is there?

    return $muPlugins['PluginOrganizerMU.class.php']['Version']." != ".get_option("PO_version_num")."<p>You are running an old version of the MU Plugin. Please use the tool provided on the settings page to move the updated version into place or manually copy ".$this->absPath."/lib/PluginOrganizerMU.class.php to ".WPMU_PLUGIN_DIR."/PluginOrganizerMU.class.php. If you don't do this the plugin will not work. This message will disappear when everything is correct.</p>";

    Then reload the page and tell me what numbers are directly below “Plugin Organizer is not set up correctly.”

    The line of code you will be replacing is this.

    return "<p>You are running an old version of the MU Plugin. Please use the tool provided on the settings page to move the updated version into place or manually copy ".$this->absPath."/lib/PluginOrganizerMU.class.php to ".WPMU_PLUGIN_DIR."/PluginOrganizerMU.class.php. If you don't do this the plugin will not work. This message will disappear when everything is correct.</p>";

    • This reply was modified 2 years, 4 months ago by  Jeff Sterup.

    Thanks again

    This indeed gives two different versions
    9.2 != 9.1.3
    But copying as suggested seems not to work

    Plugin Author Jeff Sterup

    (@foomagoo)

    Well the whole plugin isn’t going to work with the wrong version number. Are you running a caching plugin? The version number in the database is not getting updated when you update the app. Can you try deactivating and activating plugin organizer? That will run the activation function that updates the version number.

    Already tried that, but deactivated and activated again now. Still the same problem

    Plugin Author Jeff Sterup

    (@foomagoo)

    Are you running a caching plugin? Try checking the database to see that the version number has been updated in the database by running this query and replacing {DB_PREFIX} with your database prefix.

    SELECT * from {DB_PREFIX}options WHERE option_name='po_version_num'

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Plugin Organizer is not set up correctly’ is closed to new replies.