Support » Plugin: Network Subsite User Registration » Plugin not working

  • Resolved anshuak47

    (@anshuak47)


    Hi,
    Hope you are well. I have this site :https://prodicallearning.com/ with a multi-site network on it.
    When I register through site the user is added successfully and a subdmain get created.
    What I want is to allow the users to register themselves from the subdomain of the site too. I came around this plugin after some search. I followed your steps . But no change is there.

    Users on the site are getting registered to main site only, not on the sub-site.
    Please tell me if this plugin can do this. If yes then why this is not working with my site.
    Have a good day.

    • This topic was modified 11 months ago by anshuak47.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Justin Fletcher

    (@justinticktock)

    I see from your site that you are currently not using the NSUR plugin as you have the register link being redirected to https://prodicallearning.com/register/ and not the NSUR page (https://prodicallearning.com/local-signup/)

    if you have other plugins handling registration you will need to turn these off to try the NSUR plugin. With the NSUR plugin active on your network and where you have selected “Both sites and user accounts can be registered” enabled you currently will also need to have the NSUR user registration enabled on the main Network site to allow for registration to do this enable under the main site here..
    https://prodicallearning.com/wp-admin/users.php?page=registration-settings
    and enable the “Allow Users to Register” option.

    Then once a new subsite is created by a user (for example called “mynewsubsite”) if they wish to open their site up for user registration they just need to configure user registration themselves as the site administrator on their new site by going to ….
    https://prodicallearning.com/mynewsubsite/wp-admin/users.php?page=registration-settings
    and from that page enable the “Allow Users to Register” option.

    Plugin Author Justin Fletcher

    (@justinticktock)

    I’m marking as resolved.. come back here if you have an update.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Plugin not working’ is closed to new replies.