WordPress.org

Support

Support » Plugins and Hacks » Modal Dialog » [Plugin: Modal Dialog] popup ONLY AFTER a message

[Plugin: Modal Dialog] popup ONLY AFTER a message

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Yannick Lefebvre

    @jackdewey

    I just updated the Modal Dialog plugin to have an option for this. Check the box labeled “Display after new comment posted” on the dialog configuration page for the popup that should appear.

    Version 2.2.3 contains this update. Let me know if this works for you.

    And please mark this question as resolved if it does do the trick.

    thanks for your quick response and for your kindness. I have selected “Display after new comment posted” but the popup is always displayed! on blog load, on every page/link I click…

    here a screenshot with my config

    My Modal Condfig

    My test blog: http://www.revisionando.altervista.org

    Plugin Author Yannick Lefebvre

    @jackdewey

    You would also need to check the ‘Only show on specific pages and single posts’ option and leave the ‘Pages and posts to display Modal Dialog (empty for all, comma-separated IDs)’ field empty for this to behave as you want it to.

    thank you but I have already tryed it…. In this case I haven’t the popup displayed after a post checking “Only show on specific pages and single posts” and “Pages and posts to display Modal Dialog” empty 🙁

    Plugin Author Yannick Lefebvre

    @jackdewey

    Could you take a screenshot of your Modal Dialog Settings and show it to me so I can make sure that everything is configured correctly. Can you tell me on which site you are trying this so that I could test it myself and see what is happening in the javascript code?

    Thanks.

    Plugin Author Yannick Lefebvre

    @jackdewey

    I am completely stumped by this one. I can kind of see in Firebug which element has a big white gap above it but I cannot figure for the life of me what is causing it in the site design. Perhaps you know people who are more knowledgeable in web design who could help with this?

    ciao 🙂 here my setup


    setup

    http://revisionando.altervista.org

    Whit this setting I have ALWAYS popup displayed everywhere and not after a post. thank you again

    sorry, the blog to test is:

    http://revisionando.altervista.org

    Plugin Author Yannick Lefebvre

    @jackdewey

    Can you try changing line 85 from:

    $commentanchorpos = strpos($location, ‘#comment’);

    to:

    $commentanchorpos = strpos($location, ‘#comment-‘);

    Yannick

    done (in you plugin) but I have always the “thank you” message displayed on every link where I click (“home”, “about”, “programma per chattare”, etc,)!. I need to display “thank you” ONLY after a post. thank you for your hard work 🙂

    edit:
    in every case how add manually your autoclose popup in the functions.php disabling you popup in the options?

    I have added this line (copied…) to go to top of page after a post

    add_filter(‘comment_post_redirect’, ‘redirect_after_comment’);
    function redirect_after_comment($location)
    {
    return $_SERVER[“HTTP_REFERER”];
    }

    now I need something this:

    add_filter(‘comment_post_redirect’, ‘redirect_after_comment’);
    function redirect_after_comment($location)
    {

    AutoclosePopup(“Thank you for your post”,2500); < 2500 = 2.5 seconds >

    return $_SERVER[“HTTP_REFERER”];
    }

    Plugin Author Yannick Lefebvre

    @jackdewey

    Sorry for the lack of response. Are you still having problems with Modal dialog or have you figured out a way to get it working right for you? I was not clear from your last post above.

    hi 🙂 no, it’s doesn’t work. I have the popup displayed on every page load with every modal config. I haven’t found any plugin that is right for me on wordpress… I thought it was a simple thing… Thanks for your interest

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: Modal Dialog] popup ONLY AFTER a message’ is closed to new replies.
Skip to toolbar