Support » Plugin: MailPress » [Plugin: MailPress] smtp, php and sendmail all fail

  • Resolved hellothereuk

    (@hellothereuk)


    I can’t get this plugin to do anything, and have wasted far too much time trying.

      SMTP:

    as soon as i clicked “save settings” it just says:
    “proc_open” php function is not available, you need to activate Connection_php_mail add-on.
    on the top bar, doesnt even actually save the SMTP settings ive put it, because if i still try to send a test-email, the log shows “Empty user/password for SMTP connection”

      PHP MAIL:

    FAILED. Check your logs & settings ! the log then contains: “mail() has been disabled for security reasons in …./wp-content/plugins/mailpress/mp-includes/Swiftmailer/classes/Swift/Transport/SimpleMailInvoker.php on line 49”

    so deactivated that plugin, and tried

      SENDMAIL:

    FAILED. Check your logs & settings ! the log then contains: “Warning: proc_open() has been disabled for security reasons in …./wp-content/plugins/mailpress/mp-includes/Swiftmailer/classes/Swift/Transport/StreamBuffer.php on line 295

    Warning: stream_set_blocking(): supplied argument is not a valid stream resource in …./wp-content/plugins/mailpress/mp-includes/Swiftmailer/classes/Swift/Transport/StreamBuffer.php on line 296

    Warning: stream_get_contents() expects parameter 1 to be resource, null given in …./wp-content/plugins/mailpress/mp-includes/Swiftmailer/classes/Swift/Transport/StreamBuffer.php on line 297″

    Am i missing something, or is this plugin completely broken? I know the email addresses/pw’s are correct.

    http://wordpress.org/extend/plugins/mailpress/

Viewing 8 replies - 1 through 8 (of 8 total)
  • No, the plugin isn’t broken. Those errors are not the plugin’s fault. The main problems are that mail() and proc_open() have been disabled by your host. Those are PHP functions and if they have been disabled the plugin can’t do anything about it. Those stream_* errors are, I am pretty sure, a result of the proc_open() failure. You will need to talk to your host about this.

    What about the SMTP? I know the settings are correct, I even made a new email account just to test it with.

    It doesn’t appear to even try to connect, just tells me “proc_open” php function is not available, you need to activate Connection_php_mail add-on.”

    Is that required for SMTP too?

    mail() is the SMTP function in generic PHP. If mail() is disabled it doesn’t matter what your settings are. Of course there are other ways to send email in PHP but depending on the server you may or may not be able to get it working.

    Have you tried activating Connection_php_mail as instructed?

    yep, as shown above when php_mail is activated it returns

    FAILED. Check your logs & settings ! the log then contains: “mail() has been disabled for security reasons in …./wp-content/plugins/mailpress/mp-includes/Swiftmailer/classes/Swift/Transport/SimpleMailInvoker.php on line 49”

    My hosting finally replied to my ticket and said they’ve disabled phpmail because its a shared server then said:


    You need to use the SMTP authentication function instead of mail() function.
    Scott U: Please refer how to enable smtp authentication function using URL
    Scott U: http://4rapiddev.com/tips-and-tricks/sending-email-with-smtp-authentication-in-wordpress/

    I’ve installed that WP Mail SMTP plugin and configured it, and its test-page does say it works, but I guess as MailPress doesn’t use this plugin its just not going to work :/

    Plugin Author RENAUT

    (@arena)

    make sure your smtp settings are the same in WP Mail SMTP and MailPress

    once done, check all checkboxes in Settings > MailPress > Test and try to send a test mail (deactivate WP Mail SMTP to avoid any plugin conflict)

    arcadin

    (@arcadin)

    I have the same issue, nothing works (host : infomaniak)

    Tried to add SMTP auth in the sendmail function without any success… There is no details in the logs.

    WP Mail SMTP is working and send emails successfully, how can I force MailPress to use it to send ?

    ——————–
    2012-06-28 11:27:09 000000 — MAILPRESS [NOTICE] – Connecting to viuzcom1 (MP_Mail send)
    2012-06-28 11:27:09 000000 — MAILPRESS [NOTICE] – Connected (MP_Mail send)
    2012-06-28 11:27:09 000000 —
    2012-06-28 11:27:09 000000 — MAILPRESS [ERROR] – *** Mail could not be sent ***

    hellothereuk

    (@hellothereuk)

    Never did get it working, moved to a new host as I was having issues with their service anyway and now everything works. They had safe mode on and phpmail disabled, and at the same time advertising themselves as a good wordpress host *rolleyes*

    The same problem.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: MailPress] smtp, php and sendmail all fail’ is closed to new replies.