WordPress.org

Support

Support » Plugins and Hacks » MailChimp Widget » [Resolved] [Plugin: MailChimp Widget] Parse Error

[Resolved] [Plugin: MailChimp Widget] Parse Error

  • Whenever I try to active your plugin, I get the following error message:

    Parse error: syntax error, unexpected ‘{‘ in /nfs/c05/h03/mnt/74736/domains/moneythink.org/html/wp-content/plugins/mailchimp-widget/mailchimp-widget.php on line 40

    I am using WordPress 3.0.5.

    Any ideas what’s wrong?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author jameslafferty

    @jameslafferty

    Hi lpleva1,

    Which version of the plugin are you using? In the most recent version, line 40 is part of a try {} catch () {} block. If you’re using that version, I’d suspect that the culprit is your version of PHP. If you could also tell me which version of PHP you’re using, we can maybe figure out whether that’s the issue.

    Cheers,

    J.

    Plugin Author jameslafferty

    @jameslafferty

    Hi lpleva1,

    Per this post from Mythobeast, the issue is resolved when you upgrade PHP from 4 to 5.

    I’m going to mark this as resolved.

    Cheers,

    James

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] [Plugin: MailChimp Widget] Parse Error’ is closed to new replies.
Skip to toolbar