Support » Plugin: Lightbox Plus Colorbox » [Plugin: Lightbox Plus] rel="lightbox" not valid in HTML5

Viewing 9 replies - 1 through 9 (of 9 total)
  • lady_r0gue

    (@lady_r0gue)

    I have the same problem… saw some documentation elsewhere that suggested changing all the rel= entries to class= which would seem like a neat solution – tried editing various files but no joy 🙁

    Got the same Problem.

    Please fix this one, so that we can validate our pages again.

    Thanks

    Plugin Author Dan Zappone

    (@dzappone)

    Will be in the next update. Probably a check box named Generate Valid HTML5 Code. I myself have a need for this too but buggier problems got the bulk of the time. Should have another update in a day or so.

    Hi Dan,

    Do you know yet when this ‘Valid HTML5 Code’ option might be available?

    I’m hitting the same problem. I also get the following – is anyone aware whether this a Lightbox Plus thing, or the WP Gallery?

    Element dl is missing a required instance of child element dd.

    Thanks,
    Sarah

    Roger Sievers

    (@mindblossomcreations)

    On this note, when adding a gallery into a page/post the images “a href” dont have the class or rel= attached to them? I tried the beta 2.5.6 but that didnt help either?

    Is this related to the new media manager?

    http://www.larsenindustries.com/newsite/gazebos-pergolas/

    wp 3.5.1
    lbs 2.5.5

    Plugin Author Dan Zappone

    (@dzappone)

    Should be updated in latest release (2.6). Also gallery issues should also be resolved for various version of WordPress.

    Great, thank you! Just updated a client site, checked the ‘Valid HTML5’ option and the validation errors have now disappeared.

    Now off to find out how to get rid of my ‘Element dl is missing a required instance of child element dd.’ errors… I think the default WP gallery is the culprit this time…

    Plugin Author Dan Zappone

    (@dzappone)

    No problem sorry it took me so long. Let me know because my gallery code is uses their gallery code and probably passes the same problem through.

    I got as far as working out that the ‘missing dd’ error is due to not having captions set for my gallery images.

    It’s a WP gallery thing, not specific to LBP.

    It seems a bit of a flaw to me, as there are often ocassions when clients want to add a gallery with no caption. You can change the containing elements that the gallery uses on the fly via the gallery shortcode (e.g. changing dl to div etc) – but this is not ideal for clients.

    The only other way I’ve found thus far invovles re-writing the gallery completely.

    There is an old related trac ticket here: http://core.trac.wordpress.org/ticket/14819, although not sure what the solution is given Nacin’s comment.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Lightbox Plus] rel="lightbox" not valid in HTML5’ is closed to new replies.