WordPress.org

Support

Support » Plugins and Hacks » [Plugin: iSlidex] Error

[Plugin: iSlidex] Error

  • I love the plugin and having a conflict I was hoping someone could help me resolve. Whenever I activate the plugin I get the following across the top of my site

    Warning: Cannot modify header information – headers already sent by (output started at /home/content/g/o/r/gorilladesigns/html/gorilladesigns/wp-content/plugins/islidex/islidex.php:1170) in /home/content/g/o/r/gorilladesigns/html/gorilladesigns/wp-content/themes/headway-162/library/core/core-head.php on line 437

    Warning: Cannot modify header information – headers already sent by (output started at /home/content/g/o/r/gorilladesigns/html/gorilladesigns/wp-content/plugins/islidex/islidex.php:1170) in /home/content/g/o/r/gorilladesigns/html/gorilladesigns/wp-content/themes/headway-162/library/core/core-head.php on line 441

    It looks like it is a conflict of some type with my theme: Headway.

    I disabled all other plugins.

    I also get this error when I try and disable islidex in my plugin admin area.

    Warning: Cannot modify header information – headers already sent by (output started at /home/content/g/o/r/gorilladesigns/html/gorilladesigns/wp-content/plugins/islidex/islidex.php:1170) in /home/content/g/o/r/gorilladesigns/html/gorilladesigns/wp-includes/pluggable.php on line 868

    Thanks for your help.

    http://wordpress.org/extend/plugins/islidex/

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hello prudat, as we say also in our plugin description, it is not possible to have the perfect plugin, because themes are all different, installed plugins too, therefore there might always be a conflict or issue at some point.

    Could you please post here what the code is at:
    themes/headway-162/library/core/core-head.php on line 437
    themes/headway-162/library/core/core-head.php on line 441

    Also, could you please update your WordPress to the latest version 2.9.2 and tell me if you still get the error when you disable iSlidex?

    A have similar problem, but i’m using Hybrid Framework and WordPress 2.9.2

    The error occours at same line in islidex.php and pluggable.php

    Thanks for the plguin, it is all that I was looking for.

    Because we can’t reproduce your issue, I’d need you to paste here what code is at the lines where you get the error.

    This kind of errors occur because you are using themes that influence normal WordPress behaviour and it’s really hard sometimes to find a plugin solution for all the different themes out there.
    Have you already tried to use the alternative shortcodes [islidex_altern], [islidex_altern2] and [islidex_thesis] ?

    Justin Tadlock

    @greenshady

    WordPress God

    The problem you all are experiencing is likely because the islidex.php file has no closing ?> at the end of the file or the file has additional whitespace after a closing ?> tag.

    Please read the FAQ: How do I solve the headers already sent warning?

    This kind of errors occur because you are using themes that influence normal WordPress behaviour and it’s really hard sometimes to find a plugin solution for all the different themes out there.

    This is quite clearly a PHP issue with the iSlidex plugin. The error message says it all. It has nothing to do with what theme someone is using.

    Greenshady, thank you for pointing that out.
    It surprisingly worked fine for most people, including us, even without ?> but this was definitely a major oversight in v.1.8
    v.1.8.1 is now out to correct that issue.

    And yes sometimes it does depend on the theme too, just like for other plugins, this one too might get broken by it or break it.

    Hello, I am actually having the same issue as listed originally in this post.

    Here is my error:

    Warning: Cannot modify header information – headers already sent by (output started at C:\xampp\htdocs\wordpress\wp-content\plugins\islidex\islidex.php:1170) in C:\xampp\htdocs\wordpress\wp-includes\pluggable.php on line 868

    Line 1170 on islidex.php only shows this:
    <?php

    I am using WordPress version 2.9.2 and iSlideX version 1.8.1.

    Any ideas/suggestions?

    Hi! I’ve just installed and activated the plugin but it doesn’t appear under settings menu and no where else. I’m using Iblog Pro and using Fluency Admin. Any idea? Thanks in advance!

    @ DanLehman
    I cannot reproduce your issue, have you tried disabling other plugins and having the default theme to check it’s not a conflict?

    @ Miguel
    Islidex Settings link is inside the tab “Plugins”, in the admin panel.

    @dukessa I have no other plugins installed/activated. I have since uninstalled the plugin but it still effected the current theme. I had to change to a new theme to prevent the issue from recurring.

    @ DanLehman
    It’s not possible that the plugin affected your theme once it had been disabled/removed, so maybe you should try another theme?
    The plugin doesnt change anything in your theme or other plugins when it’s active, the worst thing that can happen is that the plugin js or css interferes with other plugins or with the theme js or css and viceversa and in that case it’s not always the plugin fault.
    Try to use it with another theme and let me know if you still get that issue.

    I am having the same sorts of problems with the header:
    upon activation I get:
    "The plugin generated 2 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin."

    I get different activation errors depending on the theme
    Twenty Ten 1.0.2:
    "The plugin generated 2 characters....
    WordPress Default 1.6
    "The plugin generated 1 characters....

    And on a when I logout I get:

    "Warning: Cannot modify header information - headers already sent by (output started at /home/theo3/public_html/asiel/wp-content/plugins/islidex/islidex.php:1170) in /home/theo3/public_html/asiel/wp-login.php on line 337
    So on and so forth...

    I am using WordPress 3.0.
    I have no other active plugins

    @ DanLehman
    I had the same problem.
    I solved by opening the file islider.php and editing a few lines above and below the line in 1170, removing comments and replacing blank spaces.

    @ vinycc

    it worked for me too, thx

    This bug will definitely be the one we will focus on the most in the next release, due in about 2 weeks, plus of course nice additions.
    Thanks for reporting!

    This bug has been fixed some versions ago, please flag it as resolved 🙂

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: iSlidex] Error’ is closed to new replies.
Skip to toolbar