Support » Plugin: Google Doc Embedder » Plugin is not getting activated

Viewing 5 replies - 1 through 5 (of 5 total)
  • k3davis

    (@k3davis)

    Hi Asmeet,

    Sorry for the trouble. There is a syntax error on the file and line noted in your error message that is fixed in the latest dev build. It only affects those installs where it fails to retrieve an API key. This fix will be included in the next release but if you want to patch it in the meantime it’s quite straightforward with a text editor/FTP or using the plugin editor in WordPress:

    Open the file in question (google-document-embedder\libs\lib-setup.php) and go to line 323 and change this line:

    $error = $result->get_error_message();

    to

    $error = $response->get_error_message();

    If you’d prefer I email you a patched version of the plugin directly, you can contact me via the email address in the GPL statement near the top of gviewer.php.

    Thanks for the support. It’s activated now but now i’m facing another issue. After adding media. It gets successfully added but then on my page it shows me

    “Sorry, we were unable to find the document at the original source. Verify that the document still exists.
    You can also try to download the original document by clicking here.”

    I am able to download it.

    Please help.

    Asmeet,

    I’ll need a URL of the page you’re seeing the error on to give you help with specific documents. Feel free to use the “Support” tab in GDE Settings.

    Kevin

    Hey I found a tread similar to problem I’m facing in your support section. My problem is similar to one faced by Woodtrax. It’s link is

    http://wordpress.org/support/topic/plugin-google-doc-embedder-sorry-we-are-unable-to-generate-a-view-of-the-document-at-this-time-please-try?replies=9

    I also tried the link you gave for testing. That pdf opens but pdfs on my localhost are not showing. Please help me resolving this issue.

    The plugin can be on localhost, but the embedded files cannot be. Files on localhost aren’t supported. Please read the FAQ.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Plugin is not getting activated’ is closed to new replies.