Support » Plugin: myCRED » Plugin Hook Request for future

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Gabriel

    (@designbymerovingi)

    Hey!

    Good news! This has already been asked for and there is a custom hook available for you to download in the myCRED Support forum.

    Gabriel you are AMAZING mate!

    I’ve tried to install the hook on my test site, I downloaded the zip, uploaded it to my BuddyPress (corporate by WPMUDEV) theme folder, added the ‘include_once( get_stylesheet_directory() . ‘/mycred-wp-pro-quiz-hook.php’ );’ to the functions.php file… then I get a white screen.

    How do I enable WP_DEBUG mode?

    Plugin Author Gabriel

    (@designbymerovingi)

    Are you using a child theme?

    I’m using WPMUDEV BuddyPress Corporate theme. Here’s the mycred error message:

    Declaration of myCRED_Hook_Click_Links::has_entry() should be compatible with myCRED_Hook::has_entry($action = '', $ref_id = '', $user_id = '', $data = '', $type = '') in /var/www/.../plugins/mycred/modules/mycred-module-hooks.php on line 1118 Warning: include_once(/var/www/.../themes/bp-corporate/mycred-wp-pro-quiz-hook.php): failed to open stream: No such file or directory in /var/www/.../themes/bp-corporate/functions.php on line 5 Warning: include_once(): Failed opening '/var/www/.../themes/bp-corporate/mycred-wp-pro-quiz-hook.php' for inclusion (include_path='.:') in /var/www/.../themes/bp-corporate/functions.php on line 5 Notice: wp_enqueue_script was called incorrectly

    Plugin Author Gabriel

    (@designbymerovingi)

    The code in the forum assumes you use a child theme hence the use of get_stylesheet_directory. Change:

    include_once( get_stylesheet_directory() . '/mycred-wp-pro-quiz-hook.php' );

    to:

    include_once( get_template_directory() . '/mycred-wp-pro-quiz-hook.php' );

    The issue is that WordPress can not find the file in the child theme folder (because there is none) causing an error.

    I tried this and all I’m getting is a white screen and 404 message ( ‘The requested URL /wordpress/wp-login.php was not found on this server.’), every time I remove the site andall a fresh copy of WP, I just get the same thing, nothing being found on server so can’t get into the admin panel in WP.

    This is installed on a subdomain, not my main site

    All sorted, Once again thank you so much Gabriel!!

    Keep up the good work!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Plugin Hook Request for future’ is closed to new replies.