WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Global Content Blocks] Carriage returns not inserted in posts.

[Resolved] [Plugin: Global Content Blocks] Carriage returns not inserted in posts.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author benz1

    @benz1

    Sorry, can’t access your screenshots but are you definitely adding them in the visual editor and not html? My guess is that you’re using the html editor where line breaks are ignored.

    Yes, I’m definitely using the visual editor and choosing General from the content type dropdown. It will retain other formatting I have added: Bold, italics, numbered lists. It just does not retain line breaks.

    Try these links:
    Here is a saved screenshot of my content block.
    GCB Edit

    Here is what it looks like when I insert it into a post.
    GCB Insert

    Plugin Author benz1

    @benz1

    I am unable to replicate this issue. As there is no space between your lines it looks like you used Shift-Enter to move to the next line rather than Enter on its own? I tried both, (see http://screencast.com/t/bhoqh1sR7uZ), then added the block to a post and it displayed correctly, (see http://screencast.com/t/0jIkJpVIpNhu).

    All I can suggest is it’s an issue with your configuration or a conflict with another plugin?

    I figured it out. In the TinyMCE settings, I had to make sure the following was checked:

    Stop removing the < p> and
    tags when saving and show them in the HTML editor

    Everything is working great now! Thanks for the direction 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] [Plugin: Global Content Blocks] Carriage returns not inserted in posts.’ is closed to new replies.