Support » Plugin: wp Hosting Performance Check » Plugin generating PHP Warnings

  • PHP error log is showing the warnings below every few seconds:

    Class ‘wphpc_PAnD’ is defined in persist-admin-notices-dismissal.php of the plugin. Deactivate the plugin and the warnings stop.

    [12-Feb-2019 12:56:12 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘wphpc_PAnD’ not found in /www1/f6a/www.henleyherald.com/web/wp-includes/class-wp-hook.php on line 286

    [12-Feb-2019 12:56:23 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘wphpc_PAnD’ not found in /www1/f6a/www.henleyherald.com/web/wp-includes/class-wp-hook.php on line 286

    [12-Feb-2019 12:56:38 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘wphpc_PAnD’ not found in /www1/f6a/www.henleyherald.com/web/wp-includes/class-wp-hook.php on line 286

    [12-Feb-2019 12:56:54 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘wphpc_PAnD’ not found in /www1/f6a/www.henleyherald.com/web/wp-includes/class-wp-hook.php on line 286

    [12-Feb-2019 12:57:08 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘wphpc_PAnD’ not found in /www1/f6a/www.henleyherald.com/web/wp-includes/class-wp-hook.php on line 286

    [12-Feb-2019 12:57:27 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘wphpc_PAnD’ not found in /www1/f6a/www.henleyherald.com/web/wp-includes/class-wp-hook.php on line 286

    I’ve had to turn PHP logging off because the log file became so large.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Scott Farrell

    (@sfarrell5123)

    I’ll take a look

    same error for me

    50gb on /dev/sda1 filled with error warnings.
    Site is now offline.
    `PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘wphpc_PAnD’ not found in /var/www/html/wp-includes/class-wp-hook.php on line 286′
    Deleted logs and site is back online.
    Checked logs and new logs are created with the same error.
    Deleted plugin and the logs stop.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.