WordPress.org

Support

Support » Plugins and Hacks » GrabPress » [Resolved] plugin generating php errors

[Resolved] plugin generating php errors

  • reporting this for wp version 3.5.1 and 3.5

    In both instances I get the following error when I try to view the grabpress dashboard

    Warning: json_encode() expects exactly 1 parameter, 2 given in /public_html/wp-content/plugins/grabpress/GrabPress.php on line 382

    Fatal error: Call to undefined method DateTime::sub() in /public_html/wp-content/plugins/grabpress/GrabPressAPI.php on line 568

    troubleshooting so far:
    double checked my account on grabpress, no issues there although it doesn’t seem to be reporting anything
    deactivated/reactivated plugin
    on GrabPress>account page clicking any of the radial buttons seems to refresh the page but does nothing.
    previews of existing or new feeds yields nothing

    http://wordpress.org/extend/plugins/grabpress/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author grabmedia

    @grabmedia

    Please check your PHP version:
    DateTime::sub() was added in version 5.3.0
    and
    json_encode() was added in version 5.2.0

    So I’m running 5.2.9, guess I’m right in the sweet spot of things not working. (side note would be helpful if WordPress.org tracked which plugins do not work with certain versions of PHP and MySQL I suppose)

    Took 90 minutes for my host, remane nameless but they aren’t crocodiles, to get things upgraded.

    In short it is working again, and better than I remember. Looks like a better stock of videos on my topic now too!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] plugin generating php errors’ is closed to new replies.
Skip to toolbar