WordPress.org

Support

Support » Plugins and Hacks » [Plugin: FeedWordPress] Connection Failed Error

[Plugin: FeedWordPress] Connection Failed Error

  • I’m getting the error below whenever I try to syndicate a feed.. I’ve tried multiple different sites that I know have rss feeds..

    Error: I couldn’t find any feeds at http://www._________.com/ [HTTP request error: connection failed (4)]. Try another URL

    Does anyone know how to fix it? or has anyone else had this problem?

    Thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • I’ve also tried the homepage of the feed I want and I’ve tried linking directly to the RSS feed. Nothing seems to work.

    I’m also experiencing this problem with a number of different sites which have feeds

    Same here. Funny thing is I only encounter this problem with blogs hosted on wordpress.com. Blogger and self-hosted WordPress blogs seems to be doing fine. I’m using WordPress v2.7 with FeedWordPress 2008.1214 🙂

    Same here — this plugin has stopped to work?
    If i access the feed URI directly on browsers, the feeds appear ok; but when trying to set this feed url in this plugin; connection error
    Error: I couldn't find any feeds at http://360voice.gamerdna.com/rssrecap/____ [HTTP request error: connect() timed out!]. Try another URL

    I thought I’d post and also offer no solution to this same problem. Would love to get this thing working.

    Fitzroyalty
    Member

    @fitzroyalty

    I’ve had the same problem with wordpress.com feeds using WordPress v2.7 with FeedWordPress 2008.1214. As far as I can tell the problem is the format of the wordpress.com feed, or WordPress’s ability to interpret it.

    The default rss sidebar widget fails on the same feeds that FWP fails on, so it’s not necessarily a FWP problem.

    I fed one wordpress.com feed through a yahoo pipe then imported it with FWP and it worked.

    I’ve been emailing with Charles from FWP about the fix and he’s suggested he has a possible workaround based on WordPress itself, not FWP… more details soon.

    Fitzroyalty
    Member

    @fitzroyalty

    The issue is definitely with FWP. I have recieved an email from Woorpress.com support confirming their category feeds are valid.

    I’m having this same issue, has anyone found a solution yet?

    Fitzroyalty
    Member

    @fitzroyalty

    Charles from FWP is not answering emails… so no news.

    bergamasque
    Member

    @bergamasque

    You probably need to copy these two files from the MagpieRSS-upgrade folder of feedwordpress, rss.php and rss-functions.php, into the wp-includes folder on your ftp server. Chances are it’ll work after that.

    Mind, every once in a while, you will need to perform the operation again if you’re having problems adding anymore feeds. I suspect these files may get overwritten when you update other plugins along the line. But it’s just a wild guess…

    Fitzroyalty
    Member

    @fitzroyalty

    No. This problem can happen immediately once the plugin is installed correctly with rss.php and rss-functions.php used as required. Without using those two files you get bad importing in general. Everything works correctly except WP.com feeds.

    My workaround is to dump WP.com feeds into a Pipe then add RSS of Pipe to FWP.

    popokolok
    Member

    @popokolok

    Started to get this on any possible feed I tried just today afetr upgrading to 2.8 – anyhting news? Thanks!

    top19site
    Member

    @top19site

    See this

    Error: I couldn’t find any feeds at <http://example.com/&gt; [HTTP request error: :]. Try another URL

    The best solution for you will depend on details about your own hosting situation — in particular, what version of WordPress you are using FeedWordPress with, and whether or not you are able to install new PHP modules on your web host, or, if not, whether or not you have someone who is willing to install new PHP modules for you. Unfortunately it’s not likely to be something that FeedWordPress itself can fix. But I have made some updates so that FeedWordPress will, at least, provide some more useful diagnostic information — which may help you figure out what needs to be done, or which will hep me help you figure it out, if you send the diagnostic information to me along with your support request.
    my site
    http://www.top24shop.com

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: FeedWordPress] Connection Failed Error’ is closed to new replies.