–
(@rickjoe)
Marcus, I’ve just tested it in a fresh WP install without any custom configurations, and I’m getting exactly the same behavior that dartisan and ksaffy say and I reported here. The error message is the same in all kinds of recurrences, and I’m not getting any JS problems.
Can you send me access details to that install? so I can duplicate? and also some example dates where the bug occurs.
That initial implode error is now gone with 4.0.5 but I now get that same error as the person above:
You have not defined an end date long enough to create a recurrence.
Something went wrong with the recurrence update…There was a problem saving the recurring events.
–
(@rickjoe)
Can’t give you access because it’s in a local and restricted network, but if it helps I can send you a MySQL dump so you can duplicate the installation.
For example, I tried to set up a recurrence from May 1 to Jul 31 with events happening every day, every Tuesday, and every second Tuesday, and neither of those worked.
finally! I’ve managed to reproduce the bug with the dates you gave. Anyone else with this issue, hang on, now that I can reproduce this, fixing it shouldn’t be a problem!
think I found the connection between you all, and explains why I never get an error:
who here with this issue doesn’t have a default category selected (or no categories at all) when getting this?
anyway, if that’s the problem I’m fixing that, along with other minor improvements to the recurrence feature.
Ah! I think you’ve got it with ‘category’ Marcus. I didn’t have a category, due to the fact I couldn’t actually see the category box to populate one (it was obscured by the map. I minimized the ‘owner’ box so I could get at it and it’s now allowed me to create it. Thanks! Just getting started with this plugin but it looks great, good work!
Sorted by selecting a default category here too!
ok, this fixes it on any instance I’ve looked at, so problem “solved” and fix coming in the next update. you won’t need to have a category then.
–
(@rickjoe)
Great work, Marcus. Selecting a category worked it out for me too.
@marcus: Thank you very much for your work!
I’m happy to test the new plugin-version soon.
Regards
fux
hello
chen i try to enter a new event, I have the following message:
Missing fields: event_start_date.
Dates must have correct formatting. Please use the date picker provided.
I selected a category, tried many dtae format (us, french and so on)
I don’t see the date picker…
can someone help?
Do you have javascript enabled on your theme? If so, and based on other users’ posts, it could be a conflict with another plugin that you’re using.
@simba what you have is a js issue, we have other posts on this, please don’t use unrelated posts