WordPress.org

Support

Support » Plugins and Hacks » Events Manager » [Resolved] [Plugin: Events Manager] "All Day" string

[Resolved] [Plugin: Events Manager] "All Day" string

Viewing 12 replies - 1 through 12 (of 12 total)
  • If you want to hide it you can use conditional placeholder {has_time}

    You can look the templates/forms/event/when.php file.
    Also you can look your language files in folder in includes/langs and translate “All day” string with PoEdit.
    Hope it helps!

    Thanks, but I’ve already edited the when.php file, but it still outputs “All Day”. Same with the .po file.. o.O ?

    Plugin Author Marcus

    @netweblogic

    NetWebLogic Support

    chances are what you want is to edit your formats and use conditional placeholders to display text if it’s all day.

    also, I’ll look into adding an option in the time formatting settings

    Try to edit the classes/em-event.php file.
    Around line 1130, you will find #_EVENTTIMES placeholder output.
    Change $replace = get_option('dbem_event_all_day_message');
    To $replace = "your string";
    Or if you’re usind language files $replace = __('All Day','dbem');
    I don’t know where is the dbem_event_all_day_message function so I use directly the string.

    Plugin Author Marcus

    @netweblogic

    NetWebLogic Support

    dev version allows you to set this along with the date format in Settings > Formats/Templates

    originalstormcrow

    @originalstormcrow

    I need to know which file the words “All Day” appear in. I still want the function to work, I just want to display different text.

    agelonwl

    @angelonwl

    You can change that at Settings > Formatting > Date/Time > All Day Message (using latest version 5.2.9)

    originalstormcrow

    @originalstormcrow

    Thanks for the come back agelonwl, but that is not what I asked. Your remedy requires an investment of $75 which we dont have. Again, I need to know which file the words “All Day” appear in. I still want the function to work, I just want to display different text.

    Plugin Author Marcus

    @netweblogic

    NetWebLogic Support

    No, that’s part of the main/free plugin.

    Otherwise, search for get_option(‘dbem_event_all_day_message’) in the plugin files.

    originalstormcrow

    @originalstormcrow

    The upgrade worked and was able to change the text. But the upgrade seems to have disabled my main nav menu. Its the menu that comes with Twenty Ten theme, I created custom links. Now its gone.

    Plugin Author Marcus

    @netweblogic

    NetWebLogic Support

    if you’re using Events on the home page, this is fixed in the latest dev version, which you can update automatically visiting

    events > Settings > General (tab) > Admin Tools > Check Dev-Versions (you will need to refresh your updates/plugins page a couple times to see the update available.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] [Plugin: Events Manager] "All Day" string’ is closed to new replies.
Skip to toolbar