• Resolved irina1975

    (@irina1975)


    Good day
    Why is there such a large square at the end of the first article squares per page?
    Sincerely.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author bradvin

    (@bradvin)

    @steveush – can you see why the last item in the gallery is going fullwidth?

    It’s a simple portfolio template.

    Plugin Author steveush

    (@steveush)

    Hi @irina1975,

    This is directly related to the previous issue you logged here https://wordpress.org/support/topic/your-plugin-is-not-working-properly/. You have the CSS provided earlier in the thread by @influxfooplugins still in your page. Please remove that CSS and only use the CSS I gave you in that thread. The problem will be resolved.

    Thanks

    Good day.
    I did as you said – the problem on terephones was solved. But a new problem has arisen – written in this message. This problem.
    Sincerely.

    /* fill foogallery maximum width */
    .fg-simple_portfolio .fg-item {
    max-width: 100% !important;
    }

    Plugin Author steveush

    (@steveush)

    Hi @irina1975,

    The old CSS you quoted above is still present in your page. I’m not sure where it was added to on your end but it is appearing in your page at line 287. This old CSS needs to be removed and then everything will work correctly.

    Thanks

    I did everything as you said, here are my step-by-step screenshots here (remove the brackets in the link): top-saitov-znakomstv(((.)))ru/14796-2

    This is what you wrote to me in order for me to do:

    Try adding the code shown below to your theme’s style.css or custom CSS/additional CSS area. To enable the code to affect a specific gallery, go to WordPressadmin->foogallery->galleries, edit the gallery you want and add the code to the custom CSS area.

    /* fill foogallery maximum width */
    .fg-simple_portfolio .fg-item {
    max-width: 100% !important;
    }

    The code above enables the gallery items to fill the width on both mobile and desktop to fill the voids. However, for mobile devices, what could you be referring to by using small squares? Please elaborate further.

    Kind regards,
    Blaise

    Thank you, best regards.

    Plugin Author steveush

    (@steveush)

    Hi @irina1975,

    Ok, so there’s a bit of confusion going on here. Firstly that is not the CSS I provided from the previous ticket. That is the original CSS provided by our first line support @influxfooplugins which is what is causing the last item to be displayed at full width. As they said in their response:

    The code above enables the gallery items to fill the width on both mobile and desktop to fill the voids.

    You replied after that stating you instead wanted two columns on mobile instead of one, so I was asked to provide you with that CSS. I expected you to remove the CSS provided by @influxfooplugins and replace it with the CSS I provided, the CSS I provided is currently not included in the page at all.

    Steps to fix:

    Just to be clear I’ll refer to the below CSS provided by @influxfooplugins as old CSS;

    /* fill foogallery maximum width */
    .fg-simple_portfolio .fg-item {
    	max-width: 100% !important;
    }

    1. Remove the old CSS from your style.css file.
    2. Remove the old CSS from the gallerys Custom CSS option.
    3. Now do you want the two column mobile layout to apply to all portfolio galleries?

    If your answer to #3 is Yes then add the below CSS to the bottom of your style.css file and you should be done.

    @media only screen and (max-width: 480px){
    	.foogallery.fg-simple_portfolio .fg-item {
    		margin: 5px !important;
    		width: calc(50% - 10px) !important;
    		min-width: calc(50% - 10px) !important;
    		max-width: calc(50% - 10px) !important;
    	}
    }

    If your answer to #3 is No and you only want the two column layout to be applied to a specific portfolio gallery then add the below CSS to the gallerys Custom CSS option and change the gallery ID to the current gallery. In the below CSS I used your gallery ID of foogallery-gallery-839 from the screenshot. You can see the current gallery ID within the Custom CSS option displayed above the text area.

    @media only screen and (max-width: 480px){
    	#foogallery-gallery-839.fg-simple_portfolio .fg-item {
    		margin: 5px !important;
    		width: calc(50% - 10px) !important;
    		min-width: calc(50% - 10px) !important;
    		max-width: calc(50% - 10px) !important;
    	}
    }

    Once you have done these steps and cleared any cache your issues should hopefully be resolved.

    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.