Support » Plugin: Language Switcher » Plugin error

  • Hi!

    After installing the plugin, the menu stop working, and I get the following message:

    2019/11/13 09:50:07 [error] 11811#11811: *1375383 FastCGI sent in stderr: “switcher/includes/class-language-switcher.php on line 268 PHP message: PHP Warning: Cannot assign an
    empty string to a string offset in /var/www//wp-content/plugins/language-switcher/includes/class-language-switcher.php on line 268 PHP message: PHP
    Warning: Illegal string offset ‘main’ in /var/www//wp-content/plugins/language-switcher/includes/class-language-switcher.php on line 306 PHP message: PHP
    Warning: Cannot assign an empty string to a string offset in /var/www//wp-content/plugins/language-switcher/includes/class-language-switcher.php on line
    306 PHP message: PHP Warning: Illegal string offset ‘main’ in /var/www//wp-content/plugins/language-switcher/includes/class-language-switcher.php on line
    721 PHP message: PHP Warning: Illegal string offset ‘main’ in /var/www//wp-content/plugins/language-switcher/includes/class-language-switcher.php on line
    724” while reading upstream, client: 213.148.195.143, server: doquaformacion.com, request: “GET / HTTP/1.1”, upstream: “fastcgi://127.0.0.1:8999”, host: “www.mydomain.com”,
    referrer: “https://www.mydomain.com/wp-admin/customize.php?url=https%3A%2F%2Fwww.mydomain.com%2F” 2019/11/13 09:50:12 [error] 11812#11812: *1375490 FastCGI sent in
    stderr: “PHP message: PHP Warning: Invalid argument supplied for foreach() in
    /var/www//wp-content/plugins/language-switcher/includes/class-language-switcher.php on line 771” while reading response header from upstream, client:
    83.49.29.88, server: doquaformacion.com, request: “GET
    /wp-admin/edit.php?s=&post_status=all&post_type=shop_order&_wpnonce=092fc1308b&_wp_http_referer=%2Fwp-admin%2Fedit.php%3Fpost_type%3Dshop_order&action=trash&m=0&_customer_user=&paged=1&p$
    HTTP/1.1”, upstream: “fastcgi://127.0.0.1:8999”, host: “www.mydomain.com”, referrer: “https://www.mydomain.com/wp-admin/edit.php?post_type=shop_order” 2019/11/13
    09:50:13 [error] 11812#11812: *1375490 FastCGI sent in stderr: “PHP message: PHP Warning: Invalid argument supplied for foreach() in
    /var/www//wp-content/plugins/language-switcher/includes/class-language-switcher.php on line 771” while reading response header from upstream, client:
    83.49.29.88, server: doquaformacion.com, request: “GET /wp-admin/edit.php?post_type=shop_order&paged=1&trashed=1&ids=2057&locked=0 HTTP/1.1”, upstream: “fastcgi://127.0.0.1:8999”,
    host: “www.mydomain.com”, referrer: “https://www.mydomain.com/wp-admin/edit.php?post_type=shop_order” 2019/11/13 09:50:15 [error] 11812#11812: *1375573 FastCGI sent in
    stderr: “PHP message: PHP Warning: in_array() expects parameter 2 to be array, boolean given in
    /var/www//wp-content/plugins/language-switcher/includes/class-language-switcher.php on line 509 PHP message: PHP Warning: in_array() expects parameter 2 to
    be array, boolean given in /var/www//wp-content/plugins/language-switcher/includes/class-language-switcher.php on line 509” while reading response header
    from upstream, client: 83.49.29.88, server: doquaformacion.com, request: “GET /wp-json/wc/v4/products?low_in_stock=true&page=1&per_page=1&status=publish&_locale=user HTTP/1.1”,
    upstream: “fastcgi://127.0.0.1:8999”, host: “www.mydomain.com”, referrer: “https://www.mydomain.com/wp-admin/edit.php?post_type=shop_order&paged=1&ids=2057”

    I’m running WordPress 5.2.3 on nginx with PHP 7.2

    Is the plugin compatible with WordPress 5.2.3 and Woocommerce?

    Thank you!

  • The topic ‘Plugin error’ is closed to new replies.