Support » Plugin: Edge Suite » [Plugin: Edge Suite] Error Uploading

  • Resolved jamesdonegan

    (@jamesdonegan)


    I created an Edge composition that works just fine when I run the HTML file in Safari (locally from my harddrive), but when I upload the .zip file, I get the following message:

    Aborting, no file found that matches the main edge JS filename pattern. This is not a valid composition archive.

    …then, under the page title…

    The file HomeAnim_5.zip has been uploaded.

    Errors occurred while creating the uploaded project. The import was most likely corrupted.

    http://wordpress.org/extend/plugins/edge-suite/

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Author ti2m

    (@ti2m)

    Hi,

    this basically means edge suite was not able to locate the projectname_edge.js file within the zip. Which preview version are you using?

    Would you mind uploading the zip somewhere, then I could check what’s going wrong.

    Thanks for testing, Timm

    Good morning. Thank you for responding!

    I’m using Edge 0.11.0

    I am not sure how to get you the file (tried uploading it to my FTP server for the site, but WordPress is trying to make it a page).

    Here’s the link to a Dropbox folder. I think it’ll work for you. If not, just send me your e-mail address, and I’ll authorize you.

    https://www.dropbox.com/sh/kwzv8m4jdwgl5f5/6OcvlaQ2ac

    I’ve included the unzipped file (HomeAnimation) as well as two .zip files: one that’s the un-optimized files and one that’s the “published” version. Neither works, but since I’m not sure exactly what Edge does to optimize, I figured I’d include both.

    THANK YOU for your help!

    Plugin Author ti2m

    (@ti2m)

    Hi,
    I just tested both zips on my installation and all works fine. I guess it has to do with file permissons. Can you check if /wp-content/uploads/edge_suite exists and is writable? Where are you hosting your site?

    It does exist. Permissions set to 777. I couldn’t change permissions for the subfolders.

    Still getting the same error.

    I actually don’t know where the site is hosted. I’m a freelance designer/illustrator/reluctant developer, so it’s wherever the client has been hosting their site. I even tried uninstalling/re-installing the plugin. Same error.

    I also tried deactivating all of the other plugins. Same error.

    The site I’m working on: http://staging.m6d.com

    Plugin Author ti2m

    (@ti2m)

    Hi, that is a bit strange. What directories are in the edge_suite directory? Is there an edge_tmp directory witch contains another directory like src_xxxxxxx (xxxx being a random number)?

    This is a bit strange because extracting the zip file doesn’t seem to throw an error, so the above mentioned directory should be there, but then the files should be found on the server as well. If that’s really the case then I would add a new log message to be sure what’s happening.

    You could also try to install the “Error Log Dashboard Widget” to check if wordpress logs any error messages. The domain seems to be registered through godaddy so chances are good it’s also being hosted there. From what I got godaddy can sometimes be a bit tricky.

    That directory is there, and there are tons of src_xxxxxx files — from all my failed attempts, I guess.

    So the files are getting there. It’s this error that causes me the most concern. Maybe it shouldn’t:
    “Aborting, no file found that matches the main edge JS filename pattern. This is not a valid composition archive.”

    I don’t know how to add a new log message — beyond my technical expertise — but I installed the Error Log Dashboard Widget, and it appears that the only errors are actually in that widget…. I’m pasting below.

    Warning: fopen(error_log) [function.fopen]: failed to open stream: No such file or directory in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 115

    Warning: fseek(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 117

    Warning: ftell(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 123

    Warning: ftell(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 124

    Warning: fseek(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 129

    Warning: fread(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 130

    Warning: fseek(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 132

    Warning: ftell(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 143

    Warning: ftell(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 145

    Warning: fclose(): supplied argument is not a valid stream resource in /home/msixd/public_html/staging/wp-content/plugins/error-log-dashboard-widget/error-log-dashboard-widget.php on line 148

    I added a screen grab of the directory in the Dropbox folder. I think everything is in order.

    Ugh.

    I’m sure you made a great platform. I wish something wasn’t f*ing it up. 🙂

    Plugin Author ti2m

    (@ti2m)

    Uhh, ok, lot of folders. You can delete all of them if you want. I have to check, in general folders should be deleted if something goes wrong. Have to check up on that. But the folders src_xxxx contain the files that are in the zip? Just making sure those are not empty.
    I’ll try to check up on the code and push an update later on so we have a better clue about what’s going wrong.

    The error widget doesn’t seem to be able to use fopen, that’s kind of common, so forget about the widget.

    I agree. It won’t let me delete them, and it won’t let me change their permissions.

    The folders are empty.

    Thanks for your help. I’m taking a lunch break. 🙂

    Plugin Author ti2m

    (@ti2m)

    Did the edge_suite folder have permission 777 right form the start or did you change that manually. What about the permissions for edge_tmp and project, 777? And the src_xxxx folders? If they don’t have 777 try to set it (through edge_suite and option recursive or on each folder manually) and then again try to delete them.

    I think we might be getting closer. It looks like edge suite is able to create folders but can’t delete them or add any files.

    Plugin Author ti2m

    (@ti2m)

    Ok, I changed how directories are created and added some writable tests. Maybe that fixes it. I would recommend deactivating the plugin, deleting it and all the directories with it and then install the new version.

    This is not a live site you are working on right? This would be really risky as this plugin is not meant for production at all yet.

    Thanks. I’m unable to delete the upload/edge-suite files (not sure why — even in Dreamweaver, which I’m using as my FTP client in this case). Regardless, I downloaded the new version, uninstalled the old one, and installed the new one… and the same result.

    I guess this just isn’t gonna’ work. Ugh.

    Thank you for your help.

    Plugin Author ti2m

    (@ti2m)

    I guess if the directories are not deleted they won’t be recreated and therefore permission will not be changed.

    Are you able to change permissions to 777 for the files that you can’t delete? Otherwise try to rename the edge-suite directory. That would at least be a tmp solution and you could try the new version. Would be really interesting to know which hoster this is, seems to be quiet restrictive.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Plugin: Edge Suite] Error Uploading’ is closed to new replies.