Support » Plugin: Photography Management - WordPress Photo Proofing Plugin » Plugin does not work with httpS! Image blurred

  • Resolved xy1x0

    (@xy1x0)


    From when I change my domain from http: to https:
    the PMM Premiums, does not work anymore.
    The thing i see, after disactivate the other plugins, one by one, is that Photography Management Premium load rightly his gallery photo clients, only if i check in the domain bar “load unsecurity content”. In this mode, the website comes to http (which say “website not secure” and the images load normally…. could you please help me?
    I write a support ticket from wp plugin, without answer, I asked to joined in your FB group, without answer, I write you in your FB page… no answer! I need to resolve!
    Thank you

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author M.Sc. Denis Golovin

    (@denis_golovin)

    Hi,

    which PHMM version is installed on your site and do you have the PHMM Fast Images extension installed? Since version 4.1.2 PHMM tracks changes of the WP setting “Site Address (URL)” to make https work automatically. Please go to Settings > General and make sure that the setting “Site Address (URL)” is a https URL.

    If it is a https URL you can try do deacitvate PHMM (and PHMM Fast Images if installed) and activate them again.

    If this still does not fix the issue, you can manually change the .htaccess file:
    On your server is a .htaccess file in the folder wp-content/uploads/photography_management. Replace the occurrence of “http://” with “https://”.

    I hope this helps!

    Thread Starter xy1x0

    (@xy1x0)

    Hi, thanks for your answer. In order:

    – In settings -> general the url is http:// and I can’t modify it (also if on the domain bar is https!)

    – I have installed this version: Photography Management v 4.1.3 – Photography management Premium v 4.1.2 – PHMM Fast Images v 4.1.1

    – I found the file .htaccess in my admin panel named Photography management, but when I open it, it seems that exist only for Fast image, this is the link (with httpS just there – I have not modified it

    RewriteRule ^(.+)$ https://www.cinziacostanzo.com/wp-content/plugins/phmm-fast-images/code/load.plain.php/?codeneric_load_image=1&%1&f=$1 [L,NC]

    Hope you can help me, thank you!

    Plugin Author M.Sc. Denis Golovin

    (@denis_golovin)

    Can you create a test project for me where I can see the issue?

    Thread Starter xy1x0

    (@xy1x0)

    try this one, thank you

    https://www.cinziacostanzo.com/project/text-project/

    i have not set you as client, only create a project. Is ok?

    Plugin Author M.Sc. Denis Golovin

    (@denis_golovin)

    This is a permission issue, but I am not sure why it occurs. I was not able to reproduce it on my machine. We have to discuss this on a private channel, I’ve answered your support-request mail. Please check your mails.

    PS: as soon as the issue is solved I will respond here, s.t. other people can also benefit.

    Thread Starter xy1x0

    (@xy1x0)

    Ok, so I wait your another mail, to understand where is the problem. Really thank you!

    Plugin Author M.Sc. Denis Golovin

    (@denis_golovin)

    The solution to this particular problem is to set the “Site Address (URL)” and “WordPress Address (URL)” to https too.

    I Have a similar problem here. Images I load do not load correctly since i went to https. I have checked wordpress to ensure the URL’s are both https, which they are (i recently went from http to https). I also went to htaccess file and checked it is https, which it is. Can you help resolve this issue for me too please?

    Plugin Author M.Sc. Denis Golovin

    (@denis_golovin)

    Hi,

    please provide a list of the installed plugins and the content of the file wp-conent/uploads/photography_management/.htaccess

    Regards,

    Denis

    Plugins:

    Contact Form 7
    Contact Form 7 Signature Addon
    Cookie Notice
    Duplicate Page
    Flamingo
    Google XML Sitemaps
    HappyForms
    MP Stacks
    Photography Management
    Really Simple SSL
    UpdraftPlus – Backup/Restore

    Plugin Author M.Sc. Denis Golovin

    (@denis_golovin)

    Thanks, could you please create a small test project and send me the link?

    Hi, sure, what do you mean by test page? what would you like to see?

    Plugin Author M.Sc. Denis Golovin

    (@denis_golovin)

    Click on PHMM/Project/Add new upload two or three dummy images in the gallery and send me the link (Permalink unter the title input) to this project. Make sure that the project’s access setting is “public”, so I actually can access it.

    I removed the plugin and reinstalled it and it is working again.

    It still doesnt show the images in the project like it used to for some reason, but most importantly when you go to the project on the web page the images now load.

    Not sure what the problem was or still is with regards to the backend images not showing here.

    Also, the accent color does not work. I changed it to red, but it stays blue. Maybe you can help with this?

    Would you still like me to send you a link to the project?

    Plugin Author M.Sc. Denis Golovin

    (@denis_golovin)

    What do you mean by

    It still doesnt show the images in the project like it used to for some reason, but most importantly when you go to the project on the web page the images now load.

    , could you please elaborate?

    I think a link to a test project would be helpful, if you do not want to post your site’s url here, you can contact us via our website: https://codeneric.com/contact/

    Regarding the accent color: we will fix it in the next release.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Plugin does not work with httpS! Image blurred’ is closed to new replies.