Support » Plugin: Search Inside » plugin deprecated

  • This plugin is not working anymore, because it uses a version of the Eliasis framework that is now deprecated. It causes a fatal error when activated. Are you going to fix this?

Viewing 13 replies - 1 through 13 (of 13 total)
  • oh sorry just read that it is because of the PHP version?
    but anyways, I read on Github that this framework version is deprecated…
    so that’s why I wrote this, you are going to update this plugin?

    Plugin Author Josantonius

    (@josantonius)

    Hi Dafne,

    This plugin requires at least PHP 5.6. In a few minutes I will upload a new version compatible with the latest version of Eliasis Framework.

    If you use a PHP version older than 5.6 (which for security reasons you shouldn’ t…), I can send you a modified file of the latest plugin version.

    Regards!

    thank you for your kind revision and reply,
    unfortunately I’m not managing this hosting (in an ideal world we all have php 7.0) so I checked and it is 5.5 could you please send me the correct plugin for this? (ddm333@gmail.com)
    thanks

    Plugin Author Josantonius

    (@josantonius)

    Sent 😉

    Everything’s perfect now! thank you very much for all the attention!

    Matias

    (@matiasamail)

    Hi, I have the same problem, can you send me the modified file too? Thanks!

    Plugin Author Josantonius

    (@josantonius)

    Of course, you can download a PHP 5.6 compatible version from here.

    Regards!

    Matias

    (@matiasamail)

    Thanks for the reply. I tried that one but I’m still getting the same error. The PHP version of the hosting is 5.4.17

    Plugin Author Josantonius

    (@josantonius)

    The plugin I passed you before is only tested for PHP version (5.6) 5.5. For PHP versions equal to or greater than 5.6 you can download the plugin directly from this repository.

    Version 5.4 is already 5 years old, I don’t plan provide support that version, sorry.

    Hi

    I’m on the same boat. I’m on PHP 5.5.9 and can’t change due to multiple reasons.
    I tried the zip you posted but the error is:

    Fatal error: Uncaught exception ‘Josantonius\Json\Exception\JsonException’ with message ‘Could not create file in /home/mydomain/var/www/mydomain.com/wp-content/plugins/search-inside/components/.components-states.json’ in /home/mydomain/var/www/mydomain.com.com/wp-content/plugins/search-inside/vendor/josantonius/json/src/Json.php:97 …

    Do you have a version that could run in 5.5.9?

    thanks in advance!

    Plugin Author Josantonius

    (@josantonius)

    Hi @carlosrovira,

    Your error isn’t related to this topic, it’s not even an error related to the plugin.

    The error is related to your server, the plugin doesn’t have write permissions to create that file.

    You can contact your hosting support to solve it or try it yourself.

    Regards!

    Hi,

    thanks for your response, I tried to put 777 permissions for the whole plugin, but it reports the same. The file that want to create is “.components-states.json” with a “.”?

    thanks!

    Plugin Author Josantonius

    (@josantonius)

    Yes, but you must fix the problem with the permissions, it would be useless to manually add the files, you would have the same error when overwriting them.

    Please, note that is dangerous to grant 777 permissions to directories.

    In addition to the directory permissions, the user and group must be correct.

    I’m sorry I can’t help you more.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘plugin deprecated’ is closed to new replies.