Support » Plugin: Content Warning » [Plugin: Content Warning] Version: 2.4.7

Viewing 15 replies - 1 through 15 (of 22 total)
  • Also getting the issue. Tried adding the old ajax.php into the lib folder, and renamed it to ajax.inc.php. Noob move. Doesnt work of course. 🙂 Just posting here so i get followups.

    Not working here either. I’ve gone back to the previous version.

    This appears on the header of my site after upgrading to 2.4.7

    Warning: include(lib/ajax.inc.php) [function.include]: failed to open stream: No such file or directory in /usr/home/photoenv/public_html/wordpress/wp-content/plugins/content-warning-v2/main.php on line 23

    Warning: include() [function.include]: Failed opening ‘lib/ajax.inc.php’ for inclusion (include_path=’.:/usr/local/share/pear’) in /usr/home/photoenv/public_html/wordpress/wp-content/plugins/content-warning-v2/main.php on line 23

    Warning: session_start() [function.session-start]: Cannot send session cookie – headers already sent by (output started at /usr/home/photoenv/public_html/wordpress/wp-content/plugins/content-warning-v2/main.php:23) in /usr/home/photoenv/public_html/wordpress/wp-content/plugins/si-contact-form/si-contact-form.php on line 1931

    Warning: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent (output started at /usr/home/photoenv/public_html/wordpress/wp-content/plugins/content-warning-v2/main.php:23) in /usr/home/photoenv/public_html/wordpress/wp-content/plugins/si-contact-form/si-contact-form.php on line 1931

    Plugin Author Jerry

    (@phyrax)

    Grr… this always happens when I add a new file 🙁 You guys will have a patch by midnight…. I don’t know why it’s not working but the include issue is annoying lol. Simple inclusion issue, I forgot to check the box on SVN… gahhhhh

    Plugin Author Jerry

    (@phyrax)

    Updated and working, sorry guys I need to get used to checking that in the SVN before I commit lol. Anyhow it’s fixed and proven to work. However, I did remove some “default” values from the enter/exit texts. So you will have to go to the admin panel and add that text back.

    Thanks Jerry,

    conflict is solved. Strange thing that now however happens on my configuration is that the plugin version 2.4.8 does not load. I have .htaccess password protected wp-admin folder and with new version of plugin only get the prompt for password to gain acces to the protected folder. No “warning screen” that does not seem to load without access to wp-admin.

    Any idea?

    Further only small typo ‘bug’ on the ‘Denial’ tab 😉 ‘If you everY have…’

    At least you get some feedback when things do not work.

    Thanks Jerry conflict is solved

    2.4.8 isn’t working for me. I don’t get any warning screen. Going back to 2.4.6 makes everything work fine.

    Plugin Author Jerry

    (@phyrax)

    Damsko:
    This may be due to the new Ajax using admin-ajax. I could be wrong but I’ll look into it.

    Thor:
    I guess what I’ll be doing is downloading the uploaded version to test it against the actual development version. I’ll set the stable tag back to 2.4.6 until I can figure out why its so buggy. I honestly didnd change much except the new Ajax file so I’ll start there first.

    Guys I sincerely appreciate all the feedback it helps more than you know.

    When new version uses admin-ajax.php from wp-admin folder then that explains why i get the password prompt.

    Would it be possible not to use any files from wp-admin folder?

    I think i will not want to give up my wp-admin folder protection in order to run the content warning.

    Also back to version 2.4.6.

    Thanks for looking into it.

    Plugin Author Jerry

    (@phyrax)

    Damsko:
    What I meant to say was that it uses wp-admin/admin-ajax.php, still the same but just making sure we’re on the same page.

    I’ll have a look into a work around and see what I can do.

    Hi Jerry,

    we are on same page. File is wp-admin/admin-ajax.php.

    Visitors to my site are not allowed to access that.

    When there is work around not to use anything within the wp-admin folder it would be useful for me. Then i could keep the plugin updated.

    I might also not be the only one that restricts access to wp-admin.

    Plugin Author Jerry

    (@phyrax)

    Yea I was thinking of that, I know I was also thinking of blocking my wp-admin with .htaccess

    [EDIT]
    Worst case, I’ll still include the old ajax file and give you the option of using it or the new one in the admin panel.

    Plugin Author Jerry

    (@phyrax)

    Hey thor, would you care to clear your cache and see if that’s the cause? I think your issue may be related to a cached version of the javascript file.

    @jerry: I upgraded to 2.4.8 and cleared the cache on my browser. I now have no content warning screen. To be sure I went to a computer with a fresh install of Windows and installed Firefox for the first time. Still no content warning.

    UPDATE: I take that back….It’s NOT working! There still a BIG conflict with this update!

    (Thanks Jerry conflict is solved)

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Plugin: Content Warning] Version: 2.4.7’ is closed to new replies.