WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] [Plugin: Contact Form 7] Attachments not getting attached

[Resolved] [Plugin: Contact Form 7] Attachments not getting attached

  • Hello,

    1. I’ve designed a form with attachments enabled.
    2. I’ve inserted [file-598] in the attachment text box in report design section.
    3. The form is submitted successfully, but the attachment is not delivered to my inbox.

    I’ve checked with my host, and they claim that this is a coding issue.

    What could be the problem?

Viewing 15 replies - 1 through 15 (of 23 total)
  • The form upload element:
    [file* file-598 filetypes:doc|docx|pdf|jpg|gif|zip|rar|]

    This is inserted in the attachment text field: [file-598]

    Takayuki Miyoshi
    Participant

    @takayukister

    How about the mail header?

    zenjukai
    Participant

    @ecoist

    where can the email header be found?

    Takayuki Miyoshi
    Participant

    @takayukister

    Dosn’t your mail client have a menu like “See header” or “See source of this mail”?

    I want to confirm how was the Content-Type, in specific. It should be “multipart/mixed”.

    I’ve changed the email addresses so they won’t be collected by spam bots:

    Return-Path: <digitall.web320.opentransfer.com>
    Delivered-To: serv-musavis.c0m
    Received: (qmail 3181 invoked by uid 399); 14 Mar 2009 21:00:52 -0000
    X-Spam-Checker-Version: SpamAssassin 3.2.1 (2007-05-02) on
    	mail311.opentransfer.com
    X-Spam-Level: ****
    X-Spam-Status: No, score=4.7 required=5.0 tests=FORGED_YAHOO_RCVD,HTML_MESSAGE,
    	MIME_HTML_ONLY,RDNS_NONE autolearn=disabled version=3.2.1
    Received: from unknown (HELO smh04.opentransfer.com) (98.130.2.252)
      by mail311.opentransfer.com with ESMTP; 14 Mar 2009 21:00:52 -0000
    X-Originating-IP: 98.130.2.252
    Received-SPF: none (mail311.opentransfer.com: domain at web320.opentransfer.com does not designate permitted sender hosts)
    	identity=mailfrom; client-ip=98.130.2.252;
    	envelope-from=<digi.web320.opentransfer.com>;
    Received: from smh04.opentransfer.com (smh04 [127.0.0.1])
    	by smh04.opentransfer.com (Postfix) with ESMTP id 5A1732A814CC
    	for <serv-musavis.c0m>; Sat, 14 Mar 2009 17:00:52 -0400 (EDT)
    Received: (from mail@localhost)
    	by smh04.opentransfer.com (8.13.8/8.13.8/Submit) id n2EL0qb5005099
    	for serv-musavis.c0m; Sat, 14 Mar 2009 17:00:52 -0400
    X-Authentication-Warning: smh04.opentransfer.com: mail set sender to digitall@web320.opentransfer.com using -f
    Received: from web320.opentransfer.com (web320.opentransfer.com [98.130.2.65])
    	by smh04.opentransfer.com (Postfix) with ESMTP id 3D2DA2A814A7
    	for <servi-musavis.c0m>; Sat, 14 Mar 2009 17:00:52 -0400 (EDT)
    Received: from web320.opentransfer.com (rev.opentransfer.com.60.1.130.98.in-addr.arpa [127.0.0.1])
    	by web320.openter.com (8.13.8/8.13.8) with ESMTP id n2EL0p3S030948
    	for <serv-musavis.c0m>; Sat, 14 Mar 2009 17:00:51 -0400
    Received: (from digitall@localhost)
    	by web320.opentransfer.com (8.13.8/8.13.8/Submit) id n2EL0pqQ030943;
    	Sat, 14 Mar 2009 17:00:51 -0400
    To: serv-musavis*c0m
    Subject: =?UTF-8?B?2K/Ysdiu2YjYp9iz2Kog2K7Yr9mF2KfYqiDYqtix2KzZhdmHINin2Ybar9mE?=  =?UTF-8?B?2YrYs9mKLdmB2KfYsdiz2Yo=?=
    Date: Sat, 14 Mar 2009 17:00:51 -0400
    From: =?UTF-8?B?2LPbjNivINmF2KzbjNivINi12K/YsduM?= <majidgbox-yah00.com>
    Message-ID: <5657c71050b8db7f5a430bfae6057e00@musavis.com>
    X-Priority: 3
    X-Mailer: PHPMailer (phpmailer.sourceforge.net) [version 2.0.2]
    MIME-Version: 1.0
    Content-Transfer-Encoding: 8bit
    Content-Type: text/html; charset="UTF-8"
    X-EsetId: 2DC65F25DCB432367D86

    By the way, this happens with every sender, not just yahoo emails. Even with my own personal email @mysite.com

    Content-Type: text/html; charset="UTF-8"

    This seems to be the problem. What should I do to fix it?

    Anybody here to enlighten us?
    Takayukister?!

    I tried changing the encoding in the main cf7 php file from text/html to multipart/mixed. This breaks the HTML markup in the results sent to my email account and still doesn’t attach the attachments.

    Takayuki Miyoshi
    Participant

    @takayukister

    Sorry, I’m late. digitz, do you always fail to send mails with attachment? or you can successfully send them with other form? If I can see the site, please tell me the URL.

    It was working until 3 weeks ago and then suddenly BANG! The attachments don’t come through since then.
    I designed a new form to see if that particular form was in trouble, but no, all CF7 forms are not sending in attachments.
    Take a look at it here:
    musavisDOTcom/services/test/

    Takayuki Miyoshi
    Participant

    @takayukister

    Do you have alternate email address? If so, send to the address as a test. I think it is possible that some mail filterings are working on recipient side.

    nope 🙁

    No use, switched to gmail.

    the email comes through but no attachment.

    did you notice? in the email header the content type is not as you said. it’s text/html.

    Takayukister,

    I don’t know what you changed in the new version 1.9.4, but the problem is fixed.

    I’ll have the new FARSI .po file your way ASAP. 😉

    Thank you

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Resolved] [Plugin: Contact Form 7] Attachments not getting attached’ is closed to new replies.