Support » Plugin: WP Random Post Thumbnails » Plugin conflict

  • Resolved Matt Scheidler

    (@matt6303)


    I recently installed your plugin and it accomplishes exactly what I need for random fallback featured images for my pages/posts.

    However, I am finding that when your plugin is active, I lose certain functionality within Toolset (WP-Types), particularly the Layouts plugin, where certain requests never complete. Seems to be a javascript issue.

    Upon troubleshooting, I found that if I deleted the /includes/cmb2 directory from your plugin, Layouts worked as expected.

    As a further step, I then installed the CMB2 plugin directly from the WordPress repository, leaving your plugin running but with /includes/cmb2 still deleted. I regained the access to the Settings page, but the Layouts problem returned.

    I then deactivated your plugin but left the standalone CMB2 running. While I obviously lost the functionality of your plugin, the Layouts problem went away. So I don’t believe this is a problem with CMB2 itself.

    If I can provide further details to help arrive at a resolution I will be glad to do so.

    • This topic was modified 2 years, 6 months ago by Matt Scheidler. Reason: removed inaccurate statement
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Brianna Deleasa

    (@bdeleasa)

    Hello there, and thank you very much for debugging your issue so thoroughly. I really appreciate it, it’s definitely going to help me. I’m going to try and replicate this on my end and work to resolve the issue. I’ll try and update you as soon as possible!

    Plugin Author Brianna Deleasa

    (@bdeleasa)

    Hello again!

    What version of Layouts are you currently running? I’d like to verify I’m working with the same version on my end.

    Also, could you please update to the latest version of this plugin and let me know if the issue is resolved on your end? I recently made some changes to ensure that my plugin only includes CMB2 if it’s not already being included by another plugin (like the official CMB2 plugin from the WP repository, or another plugin).

    Thanks for addressing the issue. I am taking a few days off from work but will reply with answers to your questions early next week.

    Brianna,

    I have updated your plugin to version 2.2.1 (from 2.1.9) and also updated Layouts to version 2.0.3 (from 2.0.2) and at first glance it appears as though the problem has been remedied.

    The website in question is nearing completion but not yet finished, so I will still be modifying and creating additional Layouts over the next few weeks. If I encounter any recurrence of the issue I will let you know.

    Thanks for your help!

    Plugin Author Brianna Deleasa

    (@bdeleasa)

    Great, I’m glad to hear that! Please don’t hesitate to reach out if you come across any other issues as you’re finishing up the website.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Plugin conflict’ is closed to new replies.