WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Better Search] Problem with Polish characters

[Plugin: Better Search] Problem with Polish characters

  • Hi,

    First of all, thanks for the great plugin.
    But there’s a problem. Your plugin misinterpreted Polish diacritical marks such as: ż, ć, ę, ś.
    These are letters included in the “Latin extended”, typically encoded in the UTF-8. Sometimes in ISO 8859-2.
    Your plugin replaces them with question marks.
    Any idea how to fix it?

    Thanks in advance.

    http://wordpress.org/extend/plugins/better-search/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Ajay

    @ajay

    I’ll need to check what can be done on this. The plugin uses the FULLTEXT index feature of mySQL, which could be a reason.

    What pages do you see this on?

    I see this on search results in “Popular searches” area – for example http://isomnia.pl/?s=

    Wszystkie znaki zapytania powinny być polskimi literami 😉

    Plugin Author Ajay

    @ajay

    Thanks. Let me see what I can do about it in the next version. It must be one of the stripping / XSS functions that I have in place which is causing the error.

    Thanks for putting the correct style text above. I’ll be able to duplicate the search terms on my test blog.

    Thank you very much. Waiting for next release.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Better Search] Problem with Polish characters’ is closed to new replies.