WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: BackUpWordPress] Upgraded Backup WordPress and Control Panel is inoperable

[Resolved] [Plugin: BackUpWordPress] Upgraded Backup WordPress and Control Panel is inoperable

  • I upgraded this plug-in and now can not access my control panel. I get the following message. Looking for help on how I can get back my control panel.Thankss,Tom

    [ Moderator Note: Please post code or markup snippets between backticks or use the code button. That includes log lines too. ]

    Fatal error: Uncaught exception 'Exception' with message 'Argument 1 for HMBKP_Scheduled_Backup::set_reoccurrence must be a valid cron reoccurrence or "manually"' in /home/content/t/o/m/tombeariatric/html/wp-content/plugins/backupwordpress/classes/schedule.php:463 Stack trace: #0 /home/content/t/o/m/tombeariatric/html/wp-content/plugins/backupwordpress/functions/core.php(112): HMBKP_Scheduled_Backup->set_reoccurrence('weekly') #1 /home/content/t/o/m/tombeariatric/html/wp-content/plugins/backupwordpress/plugin.php(84): hmbkp_update() #2 [internal function]: hmbkp_init('') #3 /home/content/t/o/m/tombeariatric/html/wp-includes/plugin.php(403): call_user_func_array('hmbkp_init', Array) #4 /home/content/t/o/m/tombeariatric/html/wp-admin/admin.php(111): do_action('admin_init') #5 /home/content/t/o/m/tombeariatric/html/wp-admin/index.php(10): require_once('/home/content/t...') #6 {main} thrown in /home/content/t/o/m/tombeariatric/html/wp-content/plugins/backupwordpress/classes/schedule.php on line 463

    http://wordpress.org/extend/plugins/backupwordpress/

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Author Tom Willmot
    Participant

    @willmot

    weekly is a built in cron reoccurrence.

    Can I ask which version of WordPress you are using?

    agdesignpro
    Member

    @agdesignpro

    I have the same problem. Connect through ftp and go to wp-content > plugins and delete the backupwordpress folder.

    You should be able to use the admin again.

    AG

    WordPress 3.5.2, BackupWordpress 2.3, same error!
    If I install manally an older version (2.2.4) all works correctly.

    Fatal error: Uncaught exception 'Exception' with message 'Argument 1 for HMBKP_Scheduled_Backup::set_reoccurrence must be a valid cron reoccurrence or "manually"' in /wp/wp-content/plugins/backupwordpress/classes/schedule.php:484 Stack trace: #0 /wp/wp-content/plugins/backupwordpress/functions/core.php(151): HMBKP_Scheduled_Backup->set_reoccurrence('hmbkp_daily') #1 /wp/wp-content/plugins/backupwordpress/backupwordpress.php(156): hmbkp_update() #2 [internal function]: hmbkp_init('') #3 /wp/wp-includes/plugin.php(406): call_user_func_array('hmbkp_init', Array) #4 /wp/wp-admin/admin.php(111): do_action('admin_init') #5 /wp/wp-admin/plugins.php(10): require_once('/wp/wp...') #6 {main} thrown in /wp/wp-content/plugins/backupwordpress/classes/schedule.php on line 484

    Thanks in advance for the support.

    Plugin Author Tom Willmot
    Participant

    @willmot

    Sorry to here you’re running into this, I still haven’t been able to reproduce the issue on my end. I think it’s a conflict with another plugin. Other people have reported success by first deactivating their other plugins before upgrading BackUpWordPress.

    I have deactivated all plugins installed, then I have updated BackupWordpress. Seems to be Ok. Thanks.

    Plugin Author Tom Willmot
    Participant

    @willmot

    Could you paste a list of the plugins you have activated, I’m trying to track down the conflict so I can release a work around.

    Sure. On the first installation:

    • Akismet
    • Align RSS Images
    • BackUpWordPress
    • Broken Link Checker
    • Disqus Comment System
    • Google Analytics for WordPress
    • Google XML Sitemaps
    • Jetpack by WordPress.com
    • Jetpack shortlinks for sharing buttons
    • Liveblog
    • Redirection
    • Regenerate Thumbnails
    • Simple Feed Stats
    • Select Viper’s Video Quicktags
    • WordPress SEO

    On the second installation:

    • Add Browser Search
    • Akismet
    • Align RSS Images
    • Antispam Bee
    • Audio player
    • BackUpWordPress
    • Broken Link Checker
    • Disqus Comment System
    • Disqus Recents Widget (coded by myself)
    • Efficient Related Posts
    • FCC Old Post Message
    • Focus Widget (coded by myself)
    • Google Analytics for WordPress
    • Google Authenticator
    • Google Maps for WordPress
    • Google XML Sitemaps
    • iLast.Fm
    • Jetpack by WordPress.com
    • Limit Login Attempts
    • Liveblog
    • Mail On Update
    • Mozilla Persona
    • PostLift
    • Redirection
    • Simple Feed Stats
    • SyntaxHighlighter Evolved
    • Viper’s Video Quicktags
    • WordPress SEO
    • WP Customized Login
    • WP Google Fonts

    plugins in common:

    • Akismet
    • Align RSS Images
    • BackUpWordPress
    • Broken Link Checker
    • Disqus Comment System
    • Google Analytics for WordPress
    • Google XML Sitemaps
    • Jetpack by WordPress.com
    • Liveblog
    • Redirection
    • Simple Feed Stats
    • Select Viper’s Video Quicktags
    • WordPress SEO

    On the second installation I still have version 2.2.4. If you want to suggest me which plugin switch off before doing the upgrade, I can do it (I have a backup to roll back).

    G.

    I have the same problem.

    plugins in common with Gioxx

    Akismet
    BackUpWordPress
    Broken Link Checker
    Google XML Sitemaps
    Jetpack

    I tried to disable both jetpack that broken link checker (one at a time) but the error persists (tomorrow I can try disabling other plugins)

    sasillick
    Member

    @sasillick

    I have the same problem since the upgrade.

    Plugins in common with Gioxx:

    Antipam Bee
    Backupwordpress
    Broken link checker
    Google analytics for WP
    Google XML sitemaps
    Redirection
    Wordpress SEO

    billhennings
    Member

    @billhennings

    Same issue here.. I don’t think I have any plugins in common with everyone, but here is my list.

    And in case this might be a hosting environment issue, my site’s hosted on a reseller plan at HostGator.

    • Akismet
    • Contact Form 7
    • Global Hide/Remove Admin Bar Plugin
    • Magic Members
    • Regenerate Thumbnails
    • Screets Chat
    • Site Offline or Coming Soon
    • UberMenu 2 – WordPress Mega Menu Plugin
    • WooCommerce
    • WooCommerce PayPal Pro (Classic and PayFlow Editions) Gateway
    • WooThemes Updater
    • WordPress HTTPS
    candygirl777
    Member

    @candygirl777

    I had the same problem, solved it by deleting the files out of the ftp and re-installing the current version. I didn’t run into this on my other WP site, and I have the following on both sites:

    Akismet
    All In One SEO Pack
    Google Analytics for WordPress
    Google XML Sitemaps

    I just ran into this problem for the first time after having backup wordpress installed on many sites. To get around the error, I needed to deactivate Jetpack (v2.3.2), activate BUWP and then re-activate jetpack.

    A note to the author:
    Instead of having the plugin throw an error and stay in a broken state (with no access to the admin panel), can you change the functionality to instead show an alert followed by deactivating the BUWP plugin and returning to the plugins listing.

    Thanks.
    Otherwise, fantastic plugin…great work.

    Jason

    I just updated BackUpWordPress to the latest version. Also using the newest version of WordPress.

    On the WordPress dashboard, a Server Error was displayed.

    To get around it, I went into my hosting account cPanel and deleted the backupwordpress folder from the WordPress plugins folder.

    I used to really like BackUpWordPress, but there seems to be issues in a few of the most recent updates. I hope these issues get resolved, as BackUpWordPress is the only backup plugin I’ve found that will backup an entire domain name, not simply the WordPress installation.

    Best luck.

    Plugin Author Tom Willmot
    Participant

    @willmot

    Hey Travis,

    Sorry you ran into this, it seems to be caused by a conflict with another plugin, you should be fine to simply reactivate the latest version of BackUpWordPress you shouldn’t get the error again.

    I’m currently working on a fix and will have it out shortly.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Resolved] [Plugin: BackUpWordPress] Upgraded Backup WordPress and Control Panel is inoperable’ is closed to new replies.