Support » Plugin: amr users » [Plugin: AmR Users] 2.3 Permissions

  • Resolved flatsphere

    (@flatsphere)


    Hi,

    I just upgraded to V2.3 and now I cannot view my own lists. When I rebuild the cache and click view report I get a message saying I do not have sufficient permissions to view the page. I am a full Admin. This is the same for existing lists and new lists.

    For the moment i have had to go back to the previous version

    http://wordpress.org/extend/plugins/amr-users/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author anmari

    (@anmari)

    Thanks for letting me know – I’ll look into it – Are you on a version of wp less than 3.0 ?

    That maybe causing the problem, although I thought I had coded around that.

    Plugin Author anmari

    (@anmari)

    Got it (at least works for wp 2.9!)

    Line 1090 of ameta-admin.php. Change the bit that says:

    if (current_user_can('list_users') )

    TO

    if (current_user_can('list_users') or current_user_can('edit_users'))

    The ‘list users’ capability is new in 3.0. You should then see the lists in the sidebar menu, and then the link will not “deny” you access.

    OR wait for new version up later tonight.

    Hi Anmari

    I am on 2.9.2 thanks for the fix!!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: AmR Users] 2.3 Permissions’ is closed to new replies.