Support » Plugin: Amazon Product in a Post Plugin » [Plugin: Amazon Product In a Post Plugin] warnings when WP_DEBUG active

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Don Fischer

    (@prophecy2040)

    what version are you using?

    Moderator cubecolour

    (@numeeja)

    ɹoʇɐɹǝpoɯ

    This is with WP v3.3.1 & Product in a Post v2.0.2

    Testing with twenty-eleven theme & no other plugins installed

    In the admin, at the top I get the notice:

    Notice: Undefined index: action in /.../wp-content/plugins/amazon-product-in-a-post-plugin/inc/amazon-product-in-a-post-options.php on line 154

    & four instances of:

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /.../wp-includes/functions.php on line 3551

    Also many notices within the input fields in the Amazon PIP options page:

    Notice: get_settings is deprecated since version 2.1! Use get_option() instead. in /.../wp-includes/functions.php on line 3467

    Plugin Author Don Fischer

    (@prophecy2040)

    Thanks for the information.
    The deprecated items are already set to be updated in the next version. The Undefined index item I will look into and add it to the next version update fix list.

    In the next version, the plugin will set a custom capability so that admins can turn it on or off more easily for different user levels and override the plugin default settings. It will also be easier to turn the plugin on/off for custom post types and allow for Super Admin capabilities on WordPress multi-site installs.

    Warm regards,
    Don

    Moderator cubecolour

    (@numeeja)

    ɹoʇɐɹǝpoɯ

    That sounds great Don – I’ll look forward to seeing the next version.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Amazon Product In a Post Plugin] warnings when WP_DEBUG active’ is closed to new replies.