Support » Plugin: Advanced Access Manager » [Plugin: Advanced Access Manager] Ouch – killed my testing site

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Vasyl Martyniuk

    (@vasyl_m)

    Hi Rastarr,
    Sounds like the author of WP External Links didn’t realize that somebody else can user phpQuery lib. Actually phpQuery is fantastic product. I love it.
    Ok. So to fix that u have manually modify WP External Links plugin because AAM does not cause this problem (I implemented check for existing class long time ago).
    Find a place where in WP External Links the author include phpQuery.php and wrap it in if statement :
    if (!class_exists(‘phpQuery’)){
    require …
    }
    Also contact the author of this plugin and notify him that he is a bad boy 🙂 (I kidding)

    Regards,
    Vasyl

    Contacted author as noted. Seems it killed another guy’s site too 🙂

    And thanks heaps for the uber-fast reply too and with a fix.

    Plugin Author Vasyl Martyniuk

    (@vasyl_m)

    Yeap, looks like 🙂

    Regards,
    Vasyl

    well, I found this:

    /**
    	 * wp callback
    	 */
    	public function call_wp() {
    		if ( ! is_admin() && ! is_feed() ) {
    			// Include phpQuery
    			require_once( 'phpQuery.php' );
    
    			// add wp_head for setting js vars and css style
    			add_action( 'wp_head', array( $this, 'call_wp_head' ) );

    Do you think this is what I should be changing? Not that I know what I’m doing with PHP 🙂

    Plugin Author Vasyl Martyniuk

    (@vasyl_m)

    Rastarr,
    Yeap. Just wrap:
    // Include phpQuery
    require_once( ‘phpQuery.php’ );

    in if statement specified about.

    Regards,
    Vasyl

    Way cool Vasyl.
    That worked a treat.

    Thanks Rastarr for reporting, and thanks Vasyl for the fix.

    Plugin Author Vasyl Martyniuk

    (@vasyl_m)

    Hi freelancephp,
    Appreciate your quick fix.

    Regards,
    Vasyl

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Advanced Access Manager] Ouch – killed my testing site’ is closed to new replies.