Support » Plugin: Advanced Access Manager » [Plugin: Advanced Access Manager] Continually Having to Reset Capabilties

  • I don’t know how best to describe this problem, but ever since this plugin was installed, when an existing user goes to login to the website I have to manually go in and re-save the settings for a role despite having already set them up. If a user tries to login, they get a “You do not have sufficient permission to access this.” instead of the dashboard despite the role being set to have access.

    This is quite an annoyance as every day I have dozens of users emailing me aggravated that they can not login and I spend an unnecessary amount of time going through and re-saving each website’s role settings.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Vasyl Martyniuk


    Hi my favorite triplemoons,
    Sounds like you restricted access to User’s profile in the backend.
    This is a point. New user, by default goes to My Profile page in the backend. This is how WordPress works.
    Check if my suggestion is correct.

    Also I already implemented a feature you asked few weeks ago. It’ll go alive in few weeks, but I can send you a beta version on your email.


    No, I did not restrict User’s profile access.

    A list of plugins we’re using in case this is helpful:

    – Advanced Access Manager
    – AVH First Defense Against Spam
    – Backup Buddy
    – Contact Form 7
    – Enable Multi-Site (I’m not even sure if this is one we need any longer)
    – Expire User Passwords
    – Google Analytics
    – Infinite SEO
    – Multisite User Management
    – MU Support System
    – Network Blog Manager
    – NextGEN Gallery
    – Recent Posts with Excerpts
    – Simple Login Log
    – Social
    – WPMU Dev Dashboard
    – WP Smush.It

    I’m also dealing with this and seems to start up after I update the plugin. I need help. thx

    Plugin Author Vasyl Martyniuk


    Hi guys,
    Ok. This probably has something to do with AAM caching mechanism. I had plans to rewrite this part, so I need to force this. I’ll try to reproduce it on my local and include a fix for this Sunday’s release.

    Appreciate your feedback.

    Plugin Author Vasyl Martyniuk


    By the way,
    As a quit solution try to insert into ConfigPress next settings:
    caching = “false”

    Plugin Author Vasyl Martyniuk


    Let me know if this helped.

    If I could get more clarification on the quick fix you’re suggesting?

    Plugin Author Vasyl Martyniuk


    Hi triplemoons,
    AAM has internal caching system. It means it caches user settings. After each time you click Save button, cache is cleared.
    That is why caching = “false” will stop caching.
    If this will help then I’ll not for sure that this is caching issue.


    Thanks Vasyl,
    I think I’ll wait until Sunday’s release as this is a live environment for me and I won’t be able to tell if it fixed anything until I do another update.

    Thanks so much for looking into this.


    it is work ( caching = “false” )

    thank you very much!!!

    Сначала помогло и потом опять пропали пункты



    Forum Moderator

    These are English language forums. Please use English.



    Still having this problem. I think we’ve pinpointed it down to it’s happening when users are changing/resetting their passwords.

    We PAID for this plugin and would appreciate it if it would WORK without hassle.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: Advanced Access Manager] Continually Having to Reset Capabilties’ is closed to new replies.