Support » Plugin: Adsense Optimizer » [Plugin: Adsense Optimizer] array_keys warning

  • Plugin Author gnarf

    (@gnarf)


    If you get a warning like this:

    ‘Warning: array_keys() [function.array-keys]: The first argument should be an array in /homepages/20/d108879515/htdocs/Relationship_blog/wp-content/plugins/adsenseoptimizer/adsenseoptimizer.php on line 17’

    The reason for this is usually that you use a ad type, but specified no sizes for this ad type. Check which ad types you use in your blog (in the yellow section), then scroll up to the blue section and check if all of the used ad types have at least one tick at the sizes you can choose.

    in version 3.1. this warning will be removed. nevertheless you should choose a size for your ad.

    regards

    http://wordpress.org/extend/plugins/adsenseoptimizer/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author gnarf

    (@gnarf)

    and dont forget to check the “adsense on top” settings ! also this ad type needs at least one size, that is checked in the “adsenseoptimizer” settings.

    m

    Plugin Author gnarf

    (@gnarf)

    if you have the warning with adsense on top, deactivate the plugin and activate again. that can be a solution !

    thanks !

    Plugin Author gnarf

    (@gnarf)

    if you use adsense on top you have to open BOTH settings pages (adsense optimizer AND adsense on top) and press “save settings” at least one time to save the standard settings.

    regards

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Adsense Optimizer] array_keys warning’ is closed to new replies.