Support » Plugin: WP-PageNavi » Plugin activation causes HTTP 500 error

  • Trying out some plugins and encountered server error 500
    From:
    1) WP-Invoice: Business Locations (Usability Dynamics) [UD]
    2) Snapshot Pro (WPMUDEV)

    For both, the moment I activate it, it gives the error and shuts me out from front/back end.

    Discussing with Usability Dynamics, and them doing some troubleshooting they gave the comments below. Also mentioned on the themes support forum (theme: UDesign) and Andon, the theme developer thought I might want to run it by wp-pagenavi support. The theme requires to use wp-pagenavi.

    Not quite sure how to proceed and whether wp-pagenavi commentnavi has anything to do with it as stated below. Reply from Usability Dynamics.


    “The issue is absolutely not related to our plugins. And it’s also not related to WP-Commentnavi plugin as well. But it’s related to condition which was added to incorrect place. https://www.screencast.com/t/9LTPJcUtDMG
    And now, instead of being called this condition ONLY on Front End ONLY for comments template. It’s being called on every page loading every time everywhere….
    The solution for you:
    * Find and move condition to the correct place, as asked on WP-Commentnavi plugin’s overview page
    OR
    * Deactivate WP-Commentnavi plugin to prevent such cases NOT only for our WP-Invoice BL plugin but for other ones, which are using $wp_query.
    —–

    On my part; I haven’t changed anything.

    • This topic was modified 1 year, 1 month ago by  elmopienaar.
    • This topic was modified 1 year, 1 month ago by  elmopienaar.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author Lester Chan

    (@gamerz)

    With regards to both WP-PaveNavi and WP-CommentNavi, both plugins need to be placed in the correct place and that really differs from theme to theme. As all the theme comment section are coded differently, I can’t help you on this part. I provide the plugin as is, if you need help, you have to find your own developer.

    What is the 500 server error? You need to check the logs.

    • This reply was modified 1 year, 1 month ago by  Lester Chan.
Viewing 1 replies (of 1 total)
  • The topic ‘Plugin activation causes HTTP 500 error’ is closed to new replies.