Support » Plugin: cformsII » PHP7 errors

  • Resolved Barn2Media

    (@barn2media)


    Hi, I need to update my server to PHP7. I’m using WP Engine’s PHP7 compatibility checker which is showing errors in cforms2 that need fixing before I can upgrade. Please could you do this. The errors are:

    FILE: /nas/content/live/dressdifferent/wp-content/plugins/cforms/lib_email.php
    ————————————————————————————————————————————-
    FOUND 5 ERRORS AND 1 WARNING AFFECTING 6 LINES
    ————————————————————————————————————————————-
    417 | WARNING | INI directive ‘safe_mode’ is deprecated from PHP 5.3 and forbidden from PHP 5.4.
    515 | ERROR | The use of function set_magic_quotes_runtime is discouraged from PHP version 5.3 and forbidden from PHP version 7.0
    521 | ERROR | The use of function set_magic_quotes_runtime is discouraged from PHP version 5.3 and forbidden from PHP version 7.0
    647 | ERROR | preg_replace() – /e modifier is forbidden since PHP 7.0
    648 | ERROR | preg_replace() – /e modifier is forbidden since PHP 7.0
    650 | ERROR | preg_replace() – /e modifier is forbidden since PHP 7.0
    ————————————————————————————————————————————-

    FILE: /nas/content/live/dressdifferent/wp-content/plugins/cforms/lib_email_php4.php
    ————————————————————————————————————————————-
    FOUND 6 ERRORS AND 1 WARNING AFFECTING 7 LINES
    ————————————————————————————————————————————-
    47 | ERROR | Use of deprecated PHP4 style class constructor is not supported since PHP 7
    414 | WARNING | INI directive ‘safe_mode’ is deprecated from PHP 5.3 and forbidden from PHP 5.4.
    512 | ERROR | The use of function set_magic_quotes_runtime is discouraged from PHP version 5.3 and forbidden from PHP version 7.0
    518 | ERROR | The use of function set_magic_quotes_runtime is discouraged from PHP version 5.3 and forbidden from PHP version 7.0
    644 | ERROR | preg_replace() – /e modifier is forbidden since PHP 7.0
    645 | ERROR | preg_replace() – /e modifier is forbidden since PHP 7.0
    647 | ERROR | preg_replace() – /e modifier is forbidden since PHP 7.0
    ————————————————————————————————————————————-

    FILE: /nas/content/live/dressdifferent/wp-content/plugins/cforms/phpmailer/class.phpmailer.php
    ————————————————————————————————————————————–
    FOUND 5 ERRORS AND 1 WARNING AFFECTING 6 LINES
    ————————————————————————————————————————————–
    652 | WARNING | INI directive ‘safe_mode’ is deprecated from PHP 5.3 and forbidden from PHP 5.4.
    1471 | ERROR | The use of function set_magic_quotes_runtime is discouraged from PHP version 5.3 and forbidden from PHP version 7.0
    1475 | ERROR | The use of function set_magic_quotes_runtime is discouraged from PHP version 5.3 and forbidden from PHP version 7.0
    1727 | ERROR | preg_replace() – /e modifier is forbidden since PHP 7.0
    1730 | ERROR | preg_replace() – /e modifier is forbidden since PHP 7.0
    1735 | ERROR | preg_replace() – /e modifier is forbidden since PHP 7.0
    ————————————————————————————————————————————–

    Many thanks

Viewing 4 replies - 1 through 4 (of 4 total)
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PHP7 errors’ is closed to new replies.