Support » Plugin: Bandsintown Events » PHP7 error warning _Fix

  • PHP7+ throws up the following warnings

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Bandsintown_JS_Plugin has a deprecated constructor in …… \bandsintown.php on line 16

    Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Bandsintown_JS_Widget has a deprecated constructor in ……….\bandsintown\bandsintown.php on line 282

    These can easily be fixed

    Change line18 from
    function Bandsintown_JS_Plugin() {

    to:
    function __construct() {

    and change line284 from
    function Bandsintown_JS_Widget() {

    to:
    function __construct() {

Viewing 1 replies (of 1 total)
  • Plugin Author Bandsintown

    (@kwestion505)

    Hello olimax,

    Thanks very much for reaching out and letting us know! We’ll make sure to fix this in the next release which should be coming out later this week, thanks for your patience. If you need to contact us further feel free to email us at support@bandsintown.com. Thanks!

    Best,
    Alexis

Viewing 1 replies (of 1 total)
  • The topic ‘PHP7 error warning _Fix’ is closed to new replies.