WordPress.org

Support

Support » Requests and Feedback » PHP5 support

PHP5 support

  • I am evaluating WordPress and got a hard stop by the requirements: WP requires PHP 4.3 although Support for PHP 4 has been discontinued since 2007-12-31. Please consider upgrading to PHP 5.2.

    Looking at the forums, it seems that PHP5 is causing issues with WP which does not surprise me (I have a self-developed PHP application which I had to make PHP5 compliant; it’s doable but requires some efforts).

    It is a security risk to run an application on an unsupported PHP stack

    What are the plans for PHP5?

Viewing 6 replies - 1 through 6 (of 6 total)
  • PHP5 causing problems for WP?

    This is what I was reading out of the forums. – I have not yet installed WP. I am in the planning phase.

    whooami

    @whooami

    Member

    wordpress has NO problems with PHP5 — or vice versa.

    I have been on PHP5 with WP for a few years and no problems.

    whooami

    @whooami

    Member

    as have countless others. 😛
    .
    I migrated my own blog that was working flawlessly on PHP4, to PHP5 a few months back, without a single issue. Not one.

    mailnov,

    I am evaluating WordPress and got a hard stop by the requirements: WP requires PHP 4.3

    Where the heck have you read that? The requirements page clearly says, 4.3 or greater. WordPress itself is completely oblivious to any and all differences between PHP 4 and PHP 5… This said, there may be some third-party extensions (themes, plugins, etc.) that use object-oriented programming and, therefore, may be sensitive to PHP version…

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘PHP5 support’ is closed to new replies.