Support » Plugin: MaxiCharts » PHP Warning: error

  • Resolved luciche

    (@luciche)


    Hi, I have this error:
    PHP Warning: count(): Parameter must be an array or an object that implements Countable in /var/www/html/wp-content/plugins/maxicharts/maxicharts.php on line 969,
    from a page with 2 maxicharts. Can you please help me fix it?
    Thanks

    • This topic was modified 5 months, 2 weeks ago by luciche.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • These are the 2 shortcodes for the charts:
    [gfchartsreports count_answers="1" gf_form_id="26" gf_entry_id="2456" group_fields="1" colors="#19bf05,#ED6D62,#018fde,#82483c" include="2,6,7,8" type="pie" tooltip_style="SUM" chart_js_options="title: {display: true, text: 'Exemplu calculator salariu', fontSize:22,fontFamily:'Arial',fontColor:'#757575',fontStyle:'bold',padding:5}" height="350px"]

    [gfchartsreports count_answers="1" gf_form_id="26" gf_entry_id="2456" group_fields="1" colors="#19bf05,#ED6D62,#018fde,#82483c" include="14,15" type="bar" tooltip_style="SUM" chart_js_options="title: {display: true, text: 'Exemplu comparator salariu', fontSize:22,fontFamily:'Arial',fontColor:'#757575',fontStyle:'bold',padding:5},legend: {display: false}" height="350px"]

    Am I doing something wrong?

    • This reply was modified 5 months, 2 weeks ago by luciche.
    Plugin Author maxicharts

    (@maxicharts)

    Thanks @luciche for the feedback, the bug has been fixed.
    Can you please upgrade to 1.4.9 and tell us if everything is ok ?
    Cheers!

    I’ve updated to 1.4.9 and the error is gone, but the legend is now being displayed when I use the below code to hide it.

    chart_js_options="legend: {display: false}"

    It was hidden in the previous version using the code above

    Plugin Author maxicharts

    (@maxicharts)

    Thats true, a fix has been committed right now, can you please delete/reinstall maxicharts to fix that ?

    Will all the settings be lost if I do it?

    Plugin Author maxicharts

    (@maxicharts)

    There are no settings in maxicharts 🙂

    Fixed. Thanks

    Plugin Author maxicharts

    (@maxicharts)

    With pleasure!

    Hi, I see a new error
    ‘PHP Warning: Use of undefined constant id – assumed ‘id’ (this will throw an Error in a future version of PHP) in /var/www/html/wp-content/plugins/maxicharts/maxicharts.php on line 186′

    Can you please help me fix this one as well?
    Thanks

    Plugin Author maxicharts

    (@maxicharts)

    Thanks for your feedback @luciche !
    The bug has been fixed and released in version 1.4.10+

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.