Support » Plugin: Instant Articles for WP » PHP Warning

  • I am seeing the following warnings server-side. I believe these are resulting in some 5XX errors going out in Nginx. Based on the warning, I would guess that the plugin is not set to handle drafts with empty post content…?

    2016/10/20 16:27:17 [error] 1069#0: *240477 FastCGI sent in stderr: “PHP message: PHP Warning: DOMDocument::loadHTML(): Empty string supplied as input in /XXXXXX/wp-content/plugins/fb-instant-articles/vendor/facebook/facebook-instant-articles-sdk-php/src/Facebook/InstantArticles/Transformer/Transformer.php on line 178” while reading response header from upstream, client: 172.31.46.188, server: localhost, request: “POST /wp-admin/admin-ajax.php HTTP/1.1”, upstream: “fastcgi://unix:/var/run/php5-fpm.sock:”, host: “XXXXXX”, referrer: “http://XXXXXX/wp-admin/post-new.php”

Viewing 4 replies - 1 through 4 (of 4 total)
  • I have the same error.
    Any idea please?

    Thread Starter jarad.secco

    (@jaradsecco)

    I believe the above warnings are non-fatal (they won’t crash the page render), and as such can just be ignored. Hopefully in the future the author(s) of the plugin will put in an is_null() check before the loadHTML() call to stop the warnings from being thrown.

    In the case of the 5XX server-side errors we were seeing at the time, we came to the conclusion that they were coming from a memory limit. PHP was set to a 128M limit, and in some cases certain pages were exceeding that limit (at which point they would die and throw a 500 error). The fix for that issue was to increase the value of memory_limit in the php.ini configuration file. If you are seeing 500 errors client-side, I suggest you dig deeper into your error logs to see if there are other errors (and not just warnings) buried in there.

    • This reply was modified 5 years, 7 months ago by jarad.secco.

    I see also some mysql queries like this:

    # Time: 161101 20:46:09
    # User@Host: dsso_dandrsss[dansgo_dsssr69] @ localhost []
    # Query_time: 93.176316 Lock_time: 0.050331 Rows_sent: 2218 Rows_examined: 6785
    SET timestamp=1478025969;
    SELECT option_name, option_value FROM wp_options WHERE autoload = ‘yes’;

    This repeats many times and crashes the server.
    Could it be a plugin? Which one?

    • This reply was modified 5 years, 7 months ago by dandr69.
    • This reply was modified 5 years, 7 months ago by dandr69.
    MartinCap

    (@martincap)

    I am getting this same error original PHP error posted by @jaradsecco.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘PHP Warning’ is closed to new replies.