WordPress.org

Support

Support » Plugins and Hacks » [Resolved] PHP version.

[Resolved] PHP version.

  • Hello there.
    I got the plugin last week on my site working so good. I have 4 streams in the widget lists. Today, I noticed the plugin got kind of stuck by showing a stream online (was online) by not updating at all. Even thoguh that stream gone offline for too long and other streams went online and still only showing the old one.

    I noticed a new version of the plugin, so I thought this is fix or update at its time. However, when I updated the version, I had the widget gone. Could not find a reason until I tried to re activate tthe plugin. Then, when I tried to reactivate it, I got a message saying Live Stream Badger requires PHP 5.3+. Your version: 5.2.42.

    Is there a possible solution rather than updating my current PHP version provided by my host?

    Thank you very much for the good work and support, appreciate that so much and good luck!

    http://wordpress.org/plugins/live-stream-badger/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Tadas Krivickas
    Member

    @tkrivickas

    Hi,

    I appreciate your kind words, but PHP 5.3- will not be supported. It has reached end of life 3 years ago.

    You should upgrade to 5.3 or even better to 5.4/5.5. New language features enable to write more effective code making plugin easier to maintain.

    If your host cannot do it, there are plenty of providers with up to date PHP versions like 5.5 (even free ones).

    Regards

    Thank you very much for your fast replay.
    I have contacted my host provider and I am upgrading it to 5.3 so far.
    I will let you know when it gets fixed by the upgrade.

    Thanks again.

    I got my PHP version upgraded to 5.3 now. However, I got an error when I tried to activate it which is “Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘LSB_Plugin_Run’ does not have a method ‘install’ in /***/wp-includes/plugin.php on line 429”

    Also I tried to re install the plugin, and same error applies.
    Please help, thank you.

    I am sorry for my lot of replays earlier, but I got back the message “Live Stream Badger requires PHP 5.3+. Your version: 5.2.42.”. I believe the host provider are still working on the upgrading. I will let you updated. Sorry again.

    Plugin Author Tadas Krivickas
    Member

    @tkrivickas

    "Warning: call_user_func_array() expects parameter 1 to be a valid callback, class 'LSB_Plugin_Run' does not have a method 'install' in /***/wp-includes/plugin.php on line 429"

    I haven’t got such error, but this clearly was an issue, too. Fixed in 1.4.3

    Fixed now.
    Thank a lot!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] PHP version.’ is closed to new replies.