Support » Plugin: WP Editor » php v7 incompatibility

  • when WP editor is activated the list of plugins crashes at WP Editor and fails to list further plugins. When deactivated the plugin list works fine. Is WP Editor compatible with php v7? if so what other criteria are required for it to be listed in plugins? or does it conflict with other plugins in v7?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • in the logs I get this message
    mod_fcgid: stderr: PHP Fatal error: Uncaught Error: Cannot unset string offsets in /var/www/vhosts/servicedeskinstitute.com/subdomains/test1/httpdocs/wp-content/plugins/elementor-pro/includes/admin.php:112, referer: http://test1.servicedeskinstitute.com/wp-admin/post.php?post=313&action=edit

    I second that. Do you have it in your plans to update the plugin?

    to fix this PHP 7.1 issue
    edit file wp-editor/classes/WPEditor.php
    change line 324
    $data = ”;
    to
    $data = array();

    I agree, I have it running on 250 sites myself! I would be happy to maintain it. It’s a great plugin! We have a new problem I think though, the color coding isn’t working anymore in php 7.2.14. I will post a fix to it soon. I will maintain this myself and just post the fixes to it here if need be. I just wish Benjamin Rojas would respond and give me or someone permission to pick up where he left off.

    Good to know, let me know about the color coding issue? I’m running PHP7.2.x on a few sites, I will test more as well.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘php v7 incompatibility’ is closed to new replies.