Support » Plugin: Slideshow » PHP update

  • PHP Compatibility Checker reports:

    Name: Slideshow

    FILE: /home/y42kcabc/public_html/wp/wp-content/plugins/slideshow-jquery-image-gallery/classes/SlideshowPluginWidget.php
    ———————————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————————————–
    18 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.

Viewing 3 replies - 1 through 3 (of 3 total)
  • I have the same problem. Is Stefan still supporting this plugin as it seems it hasn’t been updated for 2 years…?

    This is because the class SlideshowPluginWidget has a deprecated constructor (it’s old and php does it differently now).
    This is actually an easy fix if you have access to the file in question “/wp-content/plugins/slideshow-jquery-image-gallery/classes/SlideshowPluginWidget.php”

    Line 8 of SlideshowPluginWidget.php looks like this:

             function SlideshowPluginWidget()
              {

    change that to

             function __construct()
              {

    Mine looks like this:

           /**
             * Initializes the widget
             *
             * @since 1.2.0
             */
    // commented the old constructor out because it is deprecated 
    //      function SlideshowPluginWidget() 
    // add the new generic constructor name
            function __construct()
            {
    • This reply was modified 7 months, 1 week ago by  deweil.
    • This reply was modified 7 months, 1 week ago by  deweil. Reason: edited for clariity

    Hi, Will this plugin be compatible with php7 any time soon? Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP update’ is closed to new replies.