Support » Plugin: Slimstat Analytics » PHP notice Undefined index: country

  • Resolved slewis1000

    (@slewis1000)


    Hello,
    Since updating wordpress and slimstat last Friday I’ve been getting this PHP Notice continuously: Undefined index: country in E:\sites\public_html\wp-content\plugins\wp-slimstat\wp-slimstat.php on line 557.
    Might also be linked to this error found in Slimstat>settings>maintenance under Troubleshooting > Tracker Error:
    [27-11-17 10:49 am] 205 Your MaxMind data file is invalid. Please uninstall it using the button in Settings > Maintenance.
    I haven’t change any settings (nor ever set a country), it’s a setting I particularly care about, so happy to uninstall Maxmind, but I can’t actually see how to do that either.
    thanks,
    Simon

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi @slewis1000,

    Scroll down on page Slimstat -> Settings -> Maintenance and you will see External Data Files and button Uninstall GeoLite DB (It removes maxmind.mmdb from wp-content/uploads/wp-slimstat/).

    I recommend to you check Geolocation Precision ( Slimstat -> Settings -> Tracker ) and set it to Country (City database is bigger than Country). Test everything with “country precision” for begin.

    It’s possible to manually download GeoLite2 Country (or City) from https://dev.maxmind.com/geoip/geoip2/geolite2/, unpack it, rename GeoLite2-Country.mmdb (or GeoLite2-City.mmdb) to maxmind.mmdb and upload it into wp-content/uploads/wp-slimstat/.

    I hope that helps,
    Sasa

    Hello,
    Thanks for your swift reply. The GeoLite DB was actually installed. So I’ve installed it and that’s stopped the PHP notice and the Tracker Error too it seems.

    thanks for you help,
    Simon

    Plugin Author Jason Crouse

    (@coolmann)

    Terrific!

    Please consider writing a review for Slimstat as a token of appreciation for the support you received. It would be a nice way to say thank you and to let people know how much you value this plugin:

    https://wordpress.org/support/plugin/wp-slimstat/reviews/#new-post

    Best Regards,
    Jason

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.