Support » Plugin: Google Analyticator » PHP fatal errors

Viewing 9 replies - 1 through 9 (of 9 total)
  • Same problem here. Looks as easy to fix.

    Tracking still works.

    Its affecting the dashboard widget and the shortcode ‘[analytics]’, it’s an intermittent issue also.

    Same problem – the dashboard box sending out errors, but data still being collected. Seems related to another error post here that suggests the plugin does not work with WP 4.8. Might be time to find an alternative.

    The ga:timeOnSite metric was depricated back in April.

    Metric – ga:timeOnSite – Use ga:sessionDuration instead.
    GA Core Change Log

    In order to fix the chart on the dashboard you’ll need to edit the plug-in.

    It’s line 454 in google-analytics-summary-widget.php, just replace ga:timeOnSite with ga:sessionDuration and it will work again.

    should look like this…
    $stats = $this->api->getMetrics('ga:visits,ga:bounces,ga:entrances,ga:pageviews,ga:sessionDuration,ga:newVisits', $this->date_before, $this->date_yesterday);

    • This reply was modified 4 months, 1 week ago by  gamelust.

    @gamelust, nice catch! It was easy to see that there was a call to a deprecated function/component on the Google Analytics API, but not which one 🙂

    Ugh, now I have to manually fix dozens of sites and get Wordfence to ignore the changed file until there is a new version of this plugin…

    pembo13

    (@pembo13)

    Confirming fix posted by @gamelust

    akanksha404

    (@akanksha404)

    I am facing problem with google-analyticator plugin getting error/notice “has_cap was called with an argument that is deprecated since version 2.0.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. ” please help to solve this

    graftedin

    (@graftedin)

    When will this be fixed? If its only breaking in the dash I’d rather not fuss with manually fixing it.

    • This reply was modified 4 months ago by  graftedin.
    Plugin Author grimmdude

    (@grimmdude)

    Hi @gamelust,

    Thanks very much, this fix has been included in the recent 6.5.4 update.

    -Garrett

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.