Support » Plugin: BackWPup - WordPress Backup Plugin » PHP Error and White Screen on Back-end

  • Resolved jberg1

    (@jberg1)


    I’m getting a White Screen when trying to edit pages. I see this message in my PHP error log.
    PHP Catchable fatal error: Argument 3 passed to GuzzleHttp\Client::request() must be of the type array, string given, called in /wp-content/plugins/backwpup/vendor/guzzlehttp/guzzle/src/Client.php

    I saw you other thread about not supporting PHP 5.4. However, I’m running 5.6. I have disabled plugin and everything works again.

    Any idea on the issue or a fix?
    Thanks for your help.

    WordPress 4.9.5

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support duongcuong96

    (@duongcuong96)

    Hi @jberg1
    When do you get this error? right after plugin activate or something?
    Thanks!

    Hey duongcuong96
    It started happening after last update. Noticed when I tried to edit a page and got a white screen. Then saw the message in my Error Log on the server.

    Thought it might be a plugin conflict, but disabling this plugin was my only solution. The issue/error comes right back when re-activating. However, possible downgrading to last version might be work around also, haven’t tried that yet.

    Any thoughts what that error might be pointing to?
    Thanks for your help.

    Plugin Support duongcuong96

    (@duongcuong96)

    @jberg1
    Could you please give me your server log for better debugging the problem?
    You can PM us directly on support@backwpup.com
    Thank you very much!
    Also, what is your PHP version now?

    Ok, this morning I reactivated the plugin to try to dig further and now it magically works fine. Plugin activated, can edit pages, and no error messages in the server log.

    I’m running PHP 5.6

    Weird! Ok, nevermind.
    Thanks for your help.

    Plugin Support duongcuong96

    (@duongcuong96)

    @jberg1
    Weird :/
    but could you give me your server log to help me find actually what happens yesterday?
    thanks!

    The error came back. Not sure why.
    When I reactivated the plugin it worked fine. But then about half hour later it started the same issue. This is the only message in the log (over and over again).

    [22-May-2018 15:25:20 UTC] PHP Catchable fatal error: Argument 3 passed to GuzzleHttp\Client::request() must be of the type array, string given, called in /wp-content/plugins/backwpup/vendor/guzzlehttp/guzzle/src/Client.php on line 89 and defined in /wp-content/plugins/backwpup/vendor/guzzlehttp/guzzle/src/Client.php on line 128

    And now on another website. Different Host. Using PHP 7.0. The whole site was white screen. This error in the log.

    [22-May-2018 15:30:13 UTC] PHP Fatal error: require_once(): Failed opening required '/public_html/wp-content/plugins/backwpup/inc/class-system-requirements.php' (include_path='.:/opt/alt/php70/usr/share/pear') in /public_html/wp-content/plugins/backwpup/backwpup.php on line 551

    Probably something different. But deactivating plugin was only option.
    That logs showing the error since 5/17. Just notified by my client.

    Hmmm. Is it me? haha
    Thanks for your help.

    Same thing happening on my site – all pages white, had to force deactivate.

    Plugin Author Christina Fuchs

    (@vanvox)

    Hi @all,

    we have a new version on github fixing bugs of 3.5.0. You can download it here https://github.com/inpsyde/backwpup/archive/master.zip.
    Would be great if we get some feedback before we release on wordpress.org.

    Thanks a lot for your help!

    Plugin Support duongcuong96

    (@duongcuong96)

    @ayork @jberg1
    We have new 3.5.1 update with all bugs fixed, please update as soon as possible, thank you very much!

    I updated to 3.5.1 on both sites I was having issues with. So far so good. I will report back if any issues arise.

    Thanks for your help and the update.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘PHP Error and White Screen on Back-end’ is closed to new replies.