Support » Plugin: Read More Without Refresh » PHP error after updating to version 3.0

  • Resolved insightdes

    (@insightdes)


    We received a message that read-more-without-refresh had been deactivated due to something being wrong with its header. We deleted the plugin, and reinstalled it.

    After activating the plugin, at the top of the dashboard we see:

    Notice: Undefined index: uid in /…/wp-content/plugins/read-more-without-refresh/readmoreoptions.php on line 249

    Notice: Undefined index: label in /…/wp-content/plugins/read-more-without-refresh/readmoreoptions.php on line 249

    Notice: Undefined index: section in /…/wp-content/plugins/read-more-without-refresh/readmoreoptions.php on line 249

    Notice: Undefined index: uid in /…/wp-content/plugins/read-more-without-refresh/readmoreoptions.php on line 250

    Warning: Cannot modify header information – headers already sent by (output started at /…/wp-content/plugins/read-more-without-refresh/readmoreoptions.php:249) in /…/wp-admin/includes/misc.php on line 1144

    Help appreciated.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author George Gkouvousis

    (@gkouvousisg)

    Hi.

    I see some noticed there – which is fine in case options are not defined already.
    They should go away after manual activation.

    Did you try to re-enable the plugin manually?

    The plugin is activated. Cheers.

    Plugin Author George Gkouvousis

    (@gkouvousisg)

    Can you please set the settings in ‘RMWF Settings’ page and let me know if warnings went away?

    No, warnings still there.

    On the RMWF Settings page I see errors.

    If I click save settings, nothing changes.

    • This reply was modified 7 months, 1 week ago by  insightdes.
    • This reply was modified 7 months, 1 week ago by  insightdes.
    Plugin Author George Gkouvousis

    (@gkouvousisg)

    I advise you to take a look at it with the help of your hosting provider, since it seems that you are experiencing a misconfiguration on PHP level or related that needs troubleshooting.

    I created a new, fresh WordPress 5.0 install with clean database and I was able to activate the plugin with no errors, play around with its settings successfuly, etc.

    Hi George,

    The hosting provider has had a look at it, and can’t find any issue with the PHP settings.

    We moved from PHP 7.0 to 7.1, and the errors remained.

    The errors talk about undefined indexes inside the software, so I think this is a plugin issue rather than a hosting issue.

    Plugin Author George Gkouvousis

    (@gkouvousisg)

    Well it should be normal to receive notices but not errors, if you updated straight to 3.0.
    Updating to version 3.1 will eliminate such notices too and if you have no other PHP-related issues, will be all set.

    Please update the plugin to its latest version and post back here.

    The latest updates deactivated the plugin

    Activating the plugin still does not make things work

    You have to go to the new settings “RMWP Settings” (displayed in left admin menu below “Settings” – but not in “Settings”)

    then click Save Changes

    • This reply was modified 7 months, 1 week ago by  NightL.
    insightdes

    (@insightdes)

    Updating to 3.1 resolves the issue. Thank you George.

    Plugin Author George Gkouvousis

    (@gkouvousisg)

    Glad I know your issues are sorted out. Cheers.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘PHP error after updating to version 3.0’ is closed to new replies.