Support » Theme: Sauron » PHP Compatibility

  • Hi, I receveid the message from WordPresse that some PHP in my site (www.albertofesti.com) is not compatible.
    I run the PHP Compatibility Checker and it says that the problem is in Sauron, with the message below.
    However my Sauron theme is updated. What shall I do?

    FILE: /web/htdocs/www.albertofesti.com/home/wp-content/themes/sauron/inc/admin/WDWT_support_information.php
    ————————————————————————————————————-
    FOUND 1 ERROR AND 1 WARNING AFFECTING 2 LINES
    ————————————————————————————————————-
    67 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0; Use mysqli instead
    71 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    ————————————————————————————————————-

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi,

    We will fix this in our upcoming version of the Theme.

    Now, please open wp-content/themes/sauron/inc/admin/WDWT_support_information.php file line 68 instead of

    MySQL Version: <?php echo @mysql_get_server_info() . “\n”; ?>

    write

    MySQL Version: <?php echo mysqli_get_server_info() . “\n”; ?>

    Thank you!

    Have a nice day!

    thank you!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.