Support » Plugin: Drop Shadow Boxes » PHP Compatibility

  • Resolved Robert

    (@bob23894)


    Hi,

    I ran the “PHP Compatibility Checker” plugin to see if this plugin is compatible with PHP 7.2

    Unfortunately, for any reason, the “Drop Shadow Boxes” plugin was skipped as it was too large, according to “PHP Compatibility Checker”, to scan before the server killed the process.

    Then I still don’t know if the plugin is compatible with PHP 7.2

    Thank You !

    Robert

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Steve Henty

    (@stevehenty)

    Yes it is compatible with PHP7.2.

    Thank you !

    Hey Steve,

    The plugin shows a warning in the checker, you may wish to address this with the freemius team.

    FILE: /wp-content/plugins/drop-shadow-boxes/freemius/includes/fs-essential-functions.php
    ----------------------------------------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ----------------------------------------------------------------------------------------------------------------------------------------
     175 | WARNING | Function name "__fs" is discouraged; PHP has reserved all method names with a double underscore prefix for future use.
    ---------------------------------------------------------------------------------------------------------------------------------------
    • This reply was modified 3 months, 3 weeks ago by  snaphappyme.
    Plugin Author Steve Henty

    (@stevehenty)

    @snaphappyme This is a false positive. The Freemius team have been aware of this for a long time. The function only exists for backwards compatibility and is no longer used.

    Super, thanks for advising.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.