• Hello,

    Is there a roadmap in place to start supporting PHP 8 with this and the Pro version of the plugin? Specifically, to deal with the “PHP Deprecated: Required parameter $x follows optional parameter $y” notices. Kinsta has already rolled out PHP 8 in production as of today, and while these are just warnings, it will be great to have them cleaned out of the debug.log as soon as possible. Thank you!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author dcooney

    (@dcooney)

    hi @amddtim
    No roadmap, but thanks for the heads up. I need to do this ASAP.

    Plugin Author dcooney

    (@dcooney)

    Hi @amddtim
    Im testing PHP and I’m not seeing these deprecation notices.

    What is your shortcode?

    thanks.

    Thread Starter amddtim

    (@amddtim)

    Do you have logging turned on the the config file? I have lots of shortcodes/functions I’m using across several installs. Here’s an example of some code followed by an example of the notice.

    [ajax_load_more id="speakers_carousel" container_type="div" css_classes="speakers-carousel slick-slider" theme_repeater="speaker.php" post_type="act_speaker" posts_per_page="999" order="ASC" scroll="false" transition_container="false" destroy_after="1" custom_args=“query_year:2020" cache="true" cache_id="2799722020"]

    [18-Jan-2021 17:04:23 UTC] PHP Deprecated: Required parameter $args follows optional parameter $alm_found_posts in wp-content/plugins/ajax-load-more/core/functions.php on line 84

    Plugin Author dcooney

    (@dcooney)

    Ahh yes, I see them now.
    The Query Monitor plugin was suppressing the warnings.

    Plugin Author dcooney

    (@dcooney)

    @amddtim I added some PHP8 updates to the latest release. Let me know if you’re still seeing warnings.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘PHP 8’ is closed to new replies.