Support » Plugin: wpMandrill » PHP 7 incompatibility

  • It seems that wpMandrill is not fully compatible with PHP 7. Based on a PHP compatibility test I noticed the following warnings and errors:

    FILE: /wp-content/plugins/wpmandrill/lib/mandrill.class.php
    ————————————————————————————————————
    FOUND 2 ERRORS AND 2 WARNINGS AFFECTING 4 LINES
    ————————————————————————————————————
    431 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    511 | WARNING | INI directive ‘magic_quotes_runtime’ is deprecated since PHP 5.3 and removed since PHP 5.4
    545 | ERROR | Function set_magic_quotes_runtime() is deprecated since PHP 5.3 and removed since PHP 7.0
    551 | ERROR | Function set_magic_quotes_runtime() is deprecated since PHP 5.3 and removed since PHP 7.0
    ————————————————————————————————————

    Are there any suggestions about this (apart from using another plugin or the forked version of wpMandrill by Miller Media)?

    Thanks in advance.

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘PHP 7 incompatibility’ is closed to new replies.